summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm37
1 files changed, 22 insertions, 15 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 422d4f1959..6c80806457 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
@@ -788,29 +788,36 @@ written entirely in Python.")))
(define-public gwl
(package
(name "gwl")
- (version "0.1.1")
+ (version "0.2.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://www.guixwl.org/releases/gwl-"
- version ".tar.gz"))
+ (uri (string-append "mirror://gnu/gwl/gwl-" version ".tar.gz"))
(sha256
(base32
- "06pm967mq1wyggx7l0nfapw5s0k5qc5r9lawk2v3db868br779a7"))))
+ "0db1nvy6qzhj9kv834vrlxw7gqv3lih1n4hv5zac1zjmb61ll915"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)
+ ("graphviz" ,graphviz)))
(inputs
- `(("guile" ,guile-2.2)))
+ `(("guile" ,guile-3.0)))
(propagated-inputs
- `(("guix" ,guix)
- ("guile-commonmark" ,guile-commonmark)))
- (home-page "https://www.guixwl.org")
+ `(("guix" ,guile3.0-guix)
+ ("guile-commonmark" ,guile3.0-commonmark)
+ ("guile-gcrypt" ,guile3.0-gcrypt)
+ ("guile-pfds" ,guile3.0-pfds)
+ ("guile-syntax-highlight" ,guile3.0-syntax-highlight)
+ ("guile-wisp" ,guile3.0-wisp)))
+ (home-page "https://workflows.guix.info")
(synopsis "Workflow management extension for GNU Guix")
- (description "This project provides two subcommands to GNU Guix and
-introduces two record types that provide a workflow management extension built
-on top of GNU Guix.")
+ (description "The @dfn{Guix Workflow Language} (GWL) provides an
+extension to GNU Guix's declarative language for package management to
+automate the execution of programs in scientific workflows. The GWL
+can use process engines to integrate with various computing
+environments.")
;; The Scheme modules in guix/ and gnu/ are licensed GPL3+,
;; the web interface modules in gwl/ are licensed AGPL3+,
;; and the fonts included in this package are licensed OFL1.1.
@@ -966,7 +973,7 @@ for packaging and deployment of cross-compiled Windows applications.")
(define-public libostree
(package
(name "libostree")
- (version "2019.3")
+ (version "2020.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -974,7 +981,7 @@ for packaging and deployment of cross-compiled Windows applications.")
(version-major+minor version) "/libostree-" version ".tar.xz"))
(sha256
(base32
- "1r07yqbc9iiq0lzv1pryppd35fv695ym8r040msbfc93pmiy77y0"))))
+ "0sgx81w6skiivbr2gfhljf9nvnqfwwnwfgpqqa10fjdkjrqwvpk8"))))
(build-system gnu-build-system)
(arguments
'(#:phases