summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 506d1f94e7..3c1a4d9567 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -523,7 +523,7 @@ transactions from C or Python.")
;; Below are modules used for tests.
("python-pytest" ,python-pytest)
("python-chardet" ,python-chardet)))
- (home-page "http://diffoscope.org/")
+ (home-page "https://diffoscope.org/")
(synopsis "Compare files, archives, and directories in depth")
(description
"Diffoscope tries to get to the bottom of what makes files or directories
@@ -661,7 +661,12 @@ This package provides Conda as a library.")
(license bsd-3)))
(define-public python2-conda
- (package-with-python2 python-conda))
+ (let ((base (package-with-python2
+ (strip-python2-variant python-conda))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-enum34" ,python2-enum34)
+ ,@(package-native-inputs base))))))
(define-public conda
(package (inherit python-conda)