summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm30
1 files changed, 17 insertions, 13 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index a356a6dab7..e1e7d6a5a0 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -111,8 +111,8 @@
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
(let ((version "1.0.1")
- (commit "820429517f9cc8333704a839b4346ac4b02468c4")
- (revision 1))
+ (commit "4a54ed774913480c0f8dad3caf0cd627e4fa8ebf")
+ (revision 3))
(package
(name "guix")
@@ -128,7 +128,7 @@
(commit commit)))
(sha256
(base32
- "1vfp7ps1k1cwn8p0gsgarlxcy982hzyvb7zqnj66jqd258a1qfgh"))
+ "14m4a4bn0d5hav6mrks5d7r223knx9dpswgbsc875wgr2921na2h"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -272,6 +272,7 @@
`(("bzip2" ,bzip2)
("gzip" ,gzip)
("zlib" ,zlib) ;for 'guix publish'
+ ("lzlib" ,lzlib) ;for 'guix publish' and 'guix substitute'
("sqlite" ,sqlite)
("libgcrypt" ,libgcrypt)
@@ -547,13 +548,16 @@ transactions from C or Python.")
(define-public diffoscope
(package
(name "diffoscope")
- (version "114")
+ (version (git-version "115" "1" "7f3416ffd12572b42c814e43ac15cee44ef48155"))
(source (origin
- (method url-fetch)
- (uri (pypi-uri name version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://salsa.debian.org/reproducible-builds/diffoscope.git")
+ (commit "7f3416ffd12572b42c814e43ac15cee44ef48155")))
+ (file-name (git-file-name name version))
(sha256
(base32
- "07sma4izcqxdv0zi1s5fnsybvkc47c3vbpm372sg83q8l7rhizzp"))))
+ "1pn2rwlz5shdx7s63798wx2v7029bl5if6dlq3i2r6zsnpp0laki"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -589,7 +593,8 @@ transactions from C or Python.")
#t))
(add-before 'check 'delete-failing-test
(lambda _
- (delete-file "tests/test_tools.py") ;this requires /sbin to be on the path
+ ;; this requires /sbin to be on the path
+ (delete-file "tests/test_tools.py")
#t)))))
(inputs `(("rpm" ,rpm) ;for rpm-python
("python-file" ,python-file)
@@ -598,11 +603,10 @@ transactions from C or Python.")
("python-tlsh" ,python-tlsh)
("acl" ,acl) ;for getfacl
("colordiff" ,colordiff)
- ("xxd" ,xxd)
-
- ;; Below are modules used for tests.
- ("python-pytest" ,python-pytest)
- ("python-chardet" ,python-chardet)))
+ ("xxd" ,xxd)))
+ ;; Below are modules used for tests.
+ (native-inputs `(("python-pytest" ,python-pytest)
+ ("python-chardet" ,python-chardet)))
(home-page "https://diffoscope.org/")
(synopsis "Compare files, archives, and directories in depth")
(description