summaryrefslogtreecommitdiff
path: root/gnu/packages/onc-rpc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/onc-rpc.scm')
-rw-r--r--gnu/packages/onc-rpc.scm44
1 files changed, 42 insertions, 2 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index 61a643b037..03d51d9517 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
-;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -24,6 +24,8 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages pkg-config)
#:use-module (guix build-system gnu))
@@ -37,6 +39,7 @@
(uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
version "/libtirpc-"
version ".tar.bz2"))
+ (patches (search-patches "libtirpc-missing-headers.patch"))
(sha256
(base32
"1xchbxy0xql7yl7z4n1icj8r7dmly46i22fvm00vdjq64zlmqg3j"))))
@@ -85,7 +88,8 @@ IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
`(#:configure-flags
`("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
(inputs
- `(("libtirpc" ,libtirpc)))
+ `(("libnsl" ,libnsl)
+ ("libtirpc" ,libtirpc)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "http://rpcbind.sourceforge.net/")
@@ -95,3 +99,39 @@ IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
universal addresses.")
(license bsd-3)))
+
+(define-public libnsl
+ (package
+ (name "libnsl")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/thkukuk/libnsl/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1y6kmxmv1difzvdhx7grqzw0j2v2b74mg4kjb803m8jcgkqqx8m5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (invoke "sh" "autogen.sh"))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libtirpc" ,libtirpc)))
+ (synopsis "Public client interface for NIS(YP) and NIS+")
+ (description "Libnsl is the public client interface for the Network
+Information Service / Yellow Pages (NIS/YP) and NIS+. It includes IPv6 support.
+This library was part of glibc < 2.26, but is now distributed separately.")
+ (home-page "https://github.com/thkukuk/libnsl")
+ ;; The package is distributed under the LGPL 2.1. Some files in
+ ;; 'src/nisplus/' are LGPL 2.1+, and some files in 'src/rpcsvc/' are BSD-3.
+ (license lgpl2.1)))