summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2ec67ba7be..24f402128c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -1123,14 +1123,15 @@ instances and printing them.")
(define-public ocaml-qtest
(package
(name "ocaml-qtest")
- (version "2.5")
+ (version "2.8")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/vincent-hugot/iTeML/"
- "archive/v" version ".tar.gz"))
+ (uri (string-append "https://github.com/vincent-hugot/qtest/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1hw3jqir7w79payy4knc38fa3nxcvl7ap6y6hnqavrhpi8zqb59j"))))
+ "1ff4if64mc9c7wmhjdgnlnh6k6a713piqzr4043zzj4s5pw7smxk"))))
(build-system ocaml-build-system)
(native-inputs
`(("findlib" ,ocaml-findlib)))
@@ -1144,7 +1145,7 @@ instances and printing them.")
#:phases
(modify-phases %standard-phases
(delete 'configure))))
- (home-page "https://github.com/vincent-hugot/iTeML")
+ (home-page "https://github.com/vincent-hugot/qtest")
(synopsis "Inline (Unit) Tests for OCaml")
(description "Qtest extracts inline unit tests written using a special
syntax in comments. Those tests are then run using the oUnit framework and the
@@ -1163,6 +1164,7 @@ to use -- to sophisticated random generation of test cases.")
(method url-fetch)
(uri (string-append "https://github.com/rgrinberg/stringext"
"/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"19g6lfn03iki9f8h91hi0yiqn0b3wkxyq08b3y23wgv6jw6mssfh"))))
@@ -1242,6 +1244,7 @@ coverage information.")
(method url-fetch)
(uri (string-append "https://github.com/xguerin/bitstring"
"/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"0vy8ibrxccii1jbsk5q6yh1kxjigqvi7lhhcmizvd5gfhf7mfyc8"))
@@ -1307,6 +1310,7 @@ powerful.")
(method url-fetch)
(uri (string-append "https://github.com/janestreet/result"
"/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"1pgpfsgvhxnh0i37fkvp9j8nadns9hz9iqgabj4dr519j2gr1xvw"))))
@@ -1644,6 +1648,7 @@ lets the client choose the concrete timeline.")
(method url-fetch)
(uri (string-append "https://github.com/savonet/ocaml-ssl/archive/"
version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256 (base32
"15p7652cvzdrlqxc1af11mg07wasxr1fsaj44gcmmh6bmav7wfzq"))))
(build-system ocaml-build-system)
@@ -1678,6 +1683,7 @@ through Transport Layer Security (@dfn{TLS}) encrypted connections.")
(method url-fetch)
(uri (string-append "https://github.com/ocsigen/lwt/archive/" version
".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256 (base32
"1gbw0g8a5a4b16diqrmlhc8ilnikrm4w3jjm1zq310maqg8z0zxz"))))
(build-system ocaml-build-system)
@@ -3448,6 +3454,7 @@ and 4 (random based) according to RFC 4122.")
(method url-fetch)
(uri (string-append "https://github.com/alavrik/piqi-ocaml/"
"archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"0ngz6y8i98i5v2ma8nk6mc83pdsmf2z0ks7m3xi6clfg3zqbddrv"))))