summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c14d83c016..de2ac7cc97 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -176,20 +176,18 @@ functional, imperative and object-oriented styles of programming.")
;; …/_obuild/opam/opam.asm install P1' failed.
#:tests? #f
- #:phases (alist-cons-before
- 'build 'pre-build
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((bash (assoc-ref inputs "bash")))
- (substitute* "src/core/opamSystem.ml"
- (("\"/bin/sh\"")
- (string-append "\"" bash "/bin/sh\"")))))
- (alist-cons-before
- 'check 'pre-check
- (lambda _
- (setenv "HOME" (getcwd))
- (and (system "git config --global user.email guix@gnu.org")
- (system "git config --global user.name Guix")))
- %standard-phases))))
+ #:phases (modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda* (#:key inputs make-flags #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "src/core/opamSystem.ml"
+ (("\"/bin/sh\"")
+ (string-append "\"" bash "/bin/sh\""))))))
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (and (system "git config --global user.email guix@gnu.org")
+ (system "git config --global user.name Guix")))))))
(native-inputs
`(("git" ,git) ;for the tests
("python" ,python))) ;for the tests