summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c5f1eff540..2988810fc7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1915,11 +1915,14 @@ representation of the data.")
(name "ocaml-gen")
(version "0.5.2")
(source (origin
- (method url-fetch)
- (uri "https://github.com/c-cube/gen/archive/0.5.2.tar.gz")
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/c-cube/gen")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "01hvvynh580zxsaqg12md8m17rda0l33avjv00pij44ql6676il2"))))
+ "1h9g508rnj2j8va5nvhamzscp954vrkh0hdf4pn3d10pcfyslfg2"))))
(build-system dune-build-system)
(arguments
`(#:tests? #f; no tests