summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a4d5ede416..638a0437cc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3153,7 +3153,15 @@ without writing or generating any C!")
`(#:build-flags (list "build" "--tests" "true")
#:phases
(modify-phases %standard-phases
- (delete 'configure))))
+ (delete 'configure)
+ (add-before 'build 'fix-for-guix
+ (lambda _
+ (substitute* "src/ocb_stubblr.ml"
+ ;; Do not fail when opam is not present or initialized
+ (("error_msgf \"error running opam\"") "\"\"")
+ ;; Guix doesn't have cc, but it has gcc
+ (("\"cc\"") "\"gcc\""))
+ #t)))))
(inputs
`(("topkg" ,ocaml-topkg)
("opam" ,opam)))