summaryrefslogtreecommitdiff
path: root/gnu/packages/noweb.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/noweb.scm')
-rw-r--r--gnu/packages/noweb.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/noweb.scm b/gnu/packages/noweb.scm
index 2fcd24c6e2..77e88cc5d2 100644
--- a/gnu/packages/noweb.scm
+++ b/gnu/packages/noweb.scm
@@ -19,7 +19,7 @@
(define-module (gnu packages noweb)
#:use-module (guix packages)
- #:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix licenses)
#:use-module (gnu packages perl))
@@ -27,14 +27,16 @@
(define-public noweb
(package
(name "noweb")
- (version "2.11b")
- (source (origin
- (method url-fetch)
- (uri (string-append "ftp://www.eecs.harvard.edu/pub/nr/noweb-"
- version ".tgz"))
- (sha256
- (base32
- "10hdd6mrk26kyh4bnng4ah5h1pnanhsrhqa7qwqy6dyv3rng44y9"))))
+ (version "2.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nrnrnr/noweb")
+ (commit (string-append "v" (string-join (string-split version #\.)
+ "_")))))
+ (sha256
+ (base32 "1160i2ghgzqvnb44kgwd6s3p4jnk9668rmc15jlcwl7pdf3xqm95"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -83,11 +85,6 @@
(lambda _
;; Jump in the source.
(chdir "src")
-
- ;; The makefile reads "source: FAQ", but FAQ isn't
- ;; available.
- (substitute* "Makefile"
- (("FAQ") ""))
#t)))
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list (string-append "BIN=" out "/bin")
@@ -108,4 +105,6 @@ with other literate-programming tools. noweb uses 5 control sequences to
WEB's 27. The noweb manual is only 4 pages; an additional page explains how
to customize its LaTeX output. noweb works “out of the box” with any
programming language, and supports TeX, LaTeX, HTML, and troff back ends.")
- (license (fsf-free "https://www.cs.tufts.edu/~nr/noweb/#copyright"))))
+ (license
+ (list bsd-2 ; dual-licenced under this and…
+ (fsf-free "https://www.cs.tufts.edu/~nr/noweb/#copyright")))))