summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm132
1 files changed, 64 insertions, 68 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 56369abc41..4fc9e52ec7 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2200,84 +2200,80 @@ Ethernet and TAP interfaces is supported. Packet capture is also supported.")
(license license:gpl3+)))
(define-public hcxtools
- (let* ((commit "2ecfc9a06c2028c47522ea566ccd82b2c1f94647"))
- (package
- (name "hcxtools")
- (version (git-version "0.0.0" "1" commit))
- (home-page "https://github.com/ZerBea/hcxtools")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit commit)))
- (sha256
- (base32
- "1hzwrpmxjxl674if0pp5iq06mdi24k7ni7bh1h20isp4s40201n3"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (inputs
- `(("curl" ,curl)
- ("libpcap" ,libpcap)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
- (arguments
- `(#:make-flags (list "CC=gcc"
- (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
- #:tests? #f ;no tests
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'set-environment
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "C_INCLUDE_PATH"
- (string-append (assoc-ref inputs "curl")
- "/include:"
- (assoc-ref inputs "libpcap")
- "/include:"
- (assoc-ref inputs "openssl")
- "/include:"
- (assoc-ref inputs "zlib")
- "/include:"
+ (package
+ (name "hcxtools")
+ (version "5.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ZerBea/hcxtools.git")
+ (commit version)))
+ (sha256
+ (base32 "1bkl0j6m5q091fas99s83aclcc5kfwacmkgmyg8565z2npvnj7nf"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("libpcap" ,libpcap)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'set-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "C_INCLUDE_PATH"
+ (string-append (assoc-ref inputs "curl") "/include:"
+ (assoc-ref inputs "libpcap") "/include:"
+ (assoc-ref inputs "openssl") "/include:"
+ (assoc-ref inputs "zlib") "/include:"
(getenv "C_INCLUDE_PATH")))
#t)))))
- (synopsis "Capture wlan traffic to hashcat and John the Ripper")
- (description
- "This package contains a small set of tools to capture and convert
+ (home-page "https://github.com/ZerBea/hcxtools")
+ (synopsis "Capture wlan traffic to hashcat and John the Ripper")
+ (description
+ "This package contains a small set of tools to capture and convert
packets from wireless devices for use with hashcat or John the Ripper.")
- (license license:expat))))
+ (license license:expat)))
(define-public hcxdumptool
- (let* ((commit "f4799b5da82c5b030a6d99b02d1c1b9dc838ad36"))
- (package
- (name "hcxdumptool")
- (version (git-version "0.0.0" "1" commit))
- (home-page "https://github.com/ZerBea/hcxdumptool")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit commit)))
- (sha256
- (base32
- "0qlsin0rws9sshn12faq4spmd0ffzssal36s71vhv6gkhhga7abl"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags (list "CC=gcc"
- (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
- #:tests? #f ;no tests
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
- (synopsis "Small tool to capture packets from wlan devices")
- (description
- "Small tool to capture packets from WLAN devices. After capturing,
+ (package
+ (name "hcxdumptool")
+ (version "5.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ZerBea/hcxdumptool.git")
+ (commit version)))
+ (sha256
+ (base32 "0h2cc2dfpc83325hwqkxwn0p8qfq5gh1dg0yb1nr8bnffy0b4r4v"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/ZerBea/hcxdumptool")
+ (synopsis "Small tool to capture packets from wlan devices")
+ (description
+ "Small tool to capture packets from WLAN devices. After capturing,
upload the \"uncleaned\" cap to @url{https://wpa-sec.stanev.org/?submit} to
see if the access point or the client is vulnerable to a dictionary attack.
Convert the cap file to hccapx format and/or to WPA-PMKID-PBKDF2
hashline (16800) with @command{hcxpcaptool} from the @code{hcxtools} package
and check if the WLAN key or the master key was transmitted unencrypted.")
- (license license:expat))))
+ (license license:expat)))
(define-public dante
(package