summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm46
1 files changed, 37 insertions, 9 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c71ae4a24d..ab253013bf 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
-;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
@@ -16,7 +16,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2017, 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -98,6 +98,7 @@
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages web)
#:use-module (gnu packages wm)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml)
@@ -1203,19 +1204,18 @@ HTTP proxies.")
(define-public enet
(package
(name "enet")
- (version "1.3.13")
+ (version "1.3.14")
(source (origin
(method url-fetch)
(uri (string-append "http://enet.bespin.org/download/"
- name "-" version ".tar.gz"))
+ "enet-" version ".tar.gz"))
(sha256
(base32
- "0p53mnmjbm56wizwraznynx13fcibcxiqny110dp6a5a3w174q73"))))
+ "0w780zc6cy8yq4cskpphx0f91lzh51vh9lwyc5ll8hhamdxgbxlq"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
- (synopsis
- "Network communication layer on top of UDP")
+ (synopsis "Network communication layer on top of UDP")
(description
"ENet's purpose is to provide a relatively thin, simple and robust network
communication layer on top of UDP. The primary feature it provides is optional
@@ -1401,7 +1401,7 @@ procedure calls (RPCs).")
(define-public openvswitch
(package
(name "openvswitch")
- (version "2.8.1")
+ (version "2.10.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1409,7 +1409,7 @@ procedure calls (RPCs).")
version ".tar.gz"))
(sha256
(base32
- "14rqqhfyv49irz8ag0qbv9jn8z0bn3qzxir3r074y16p4sg4674d"))))
+ "103wi6k8xal0z1pyy680gms56skagh6jawa2ja588ljr55jcg4sg"))))
(build-system gnu-build-system)
(arguments
'(;; FIXME: many tests fail with:
@@ -2367,3 +2367,31 @@ communication over HTTP.")
be used to manage peer-to-peer network connections as needed for real time
communication.")
(license license:gpl3+)))
+
+(define-public frrouting
+ (package
+ (name "frrouting")
+ (version "6.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/FRRouting/frr/releases/"
+ "download/frr-" version "/frr-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "0xfrvi62w8qlh46f504ka0skb7pm0g0p8vmdng4w90gsbirlzpdd"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("c-ares" ,c-ares)
+ ("json-c" ,json-c)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://frrouting.org/")
+ (synopsis "IP routing protocol suite")
+ (description "FRRouting (FRR) is an IP routing protocol suite which includes
+protocol daemons for BGP, IS-IS, LDP, OSPF, PIM, and RIP. ")
+ (license license:gpl2+)))