summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm64
1 files changed, 33 insertions, 31 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index bd2481dc78..57dd86d177 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -167,7 +167,7 @@ or, more generally, MAC addresses of the same category of hardware.")
(substitute* "src/Makefile"
(("^TESTS = .*") "TESTS = \n"))
#t)))))
- (home-page "http://www.remlab.net/miredo/")
+ (home-page "https://www.remlab.net/miredo/")
(synopsis "Teredo IPv6 tunneling software")
(description
"Miredo is an implementation (client, relay, server) of the Teredo
@@ -342,33 +342,35 @@ between different versions of ØMQ.")
(license license:mpl2.0)))
(define-public cppzmq
- (let ((revision "0")
- (commit "d9f0f016c07046742738c65e1eb84722ae32d7d4"))
- (package
- (name "cppzmq")
- (version (string-append "4.2.2-" revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/zeromq/cppzmq")
- (commit commit)))
- (sha256
- (base32
- "1gmqlm00y6xpa5m6d4ajq3ww63n2w7h4sy997wj81vcqmqx45b1f"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; No tests.
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("zeromq" ,zeromq)))
- (home-page "http://zeromq.org")
- (synopsis "C++ bindings for the ØMQ messaging library")
- (description
- "This package provides header-only C++ bindings for ØMQ. The header
+ (package
+ (name "cppzmq")
+ (version "4.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zeromq/cppzmq")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "19acx2bzi4n6fdnfgkja1nds7m1bwg8lw5vfcijrx9fv75pa7m8h"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(;; FIXME: The test suite requires downloading Catch and custom
+ ;; CMake targets, and refuses to use the system version.
+ ;; See <https://github.com/zeromq/cppzmq/issues/334>.
+ #:tests? #f
+ #:configure-flags '("-DCPPZMQ_BUILD_TESTS=OFF")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("zeromq" ,zeromq)))
+ (home-page "http://zeromq.org")
+ (synopsis "C++ bindings for the ØMQ messaging library")
+ (description
+ "This package provides header-only C++ bindings for ØMQ. The header
files contain direct mappings of the abstractions provided by the ØMQ C API.")
- (license license:expat))))
+ (license license:expat)))
(define-public librdkafka
(package
@@ -550,7 +552,7 @@ test_parse_format_ipv(4(|_listen_all|_mapped_ipv6)|6)\\);")
("zlib" ,zlib)))
(native-inputs `(("check" ,check)
("pkg-config" ,pkg-config)))
- (home-page "http://code.kryo.se/iodine/")
+ (home-page "https://code.kryo.se/iodine/")
(synopsis "Tunnel IPv4 data through a DNS server")
(description "Iodine tunnels IPv4 data through a DNS server. This
can be useful in different situations where internet access is firewalled, but
@@ -2707,14 +2709,14 @@ maximum extent possible.")
(define-public batctl
(package
(name "batctl")
- (version "2019.5")
+ (version "2020.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://downloads.open-mesh.org/batman/releases/batman-adv-"
version "/batctl-" version ".tar.gz"))
(sha256
- (base32 "1b9w4636dq8m38nzr8j0v0j3b0vdsw84c58c2isc33h66dx8brgz"))))
+ (base32 "01414ywhlb2b9ng9d5kd5rr1s7wzvi234j8hj6ra2spn92qykvv0"))))
(inputs
`(("libnl" ,libnl)))
(native-inputs