summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm51
1 files changed, 44 insertions, 7 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ffee9d6245..1fa142120e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -78,6 +79,7 @@
#:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
#:use-module (gnu packages rsync)
+ #:use-module (gnu packages sdl)
#:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages texlive)
@@ -312,7 +314,10 @@ interface. It is implemented as a frontend to @code{klick}.")
(add-before 'configure 'prepare-configuration
(lambda _
(substitute* "configure"
- (("SHELL=/bin/sh") "SHELL=sh"))
+ (("SHELL=/bin/sh") "SHELL=sh")
+ ;; When checking the fontforge version do not consider the
+ ;; version string that's part of the directory.
+ (("head -n") "tail -n"))
(setenv "out" "www")
(setenv "conf" "www")
#t))
@@ -1068,14 +1073,14 @@ computer's keyboard.")
(define-public qtractor
(package
(name "qtractor")
- (version "0.7.3")
+ (version "0.7.5")
(source (origin
(method url-fetch)
(uri (string-append "http://downloads.sourceforge.net/qtractor/"
"qtractor-" version ".tar.gz"))
(sha256
(base32
- "1vy4297myyqk0k58nzybgvgklckhngpdcnmp98k0rq98dirclbl7"))))
+ "0drqzp1rbqmqiwdzc9n3307y8rm882fha3awy5qlvir5ma2mwl80"))))
(build-system gnu-build-system)
(arguments `(#:tests? #f)) ; no "check" target
(inputs
@@ -1198,9 +1203,8 @@ MusicBrainz database.")
(build-system python-build-system)
(home-page "https://github.com/echonest/pyechonest")
(synopsis "Python interface to The Echo Nest APIs")
- (description "Pyechonest is an open source Python library for the Echo Nest
-API. With Pyechonest you have Python access to the entire set of API methods
-including:
+ (description "Pyechonest is a Python library for the Echo Nest API. With
+Pyechonest you have Python access to the entire set of API methods including:
@enumerate
@item artist - search for artists by name, description, or attribute, and get
@@ -1272,13 +1276,16 @@ websites such as Libre.fm.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-HOME
- (lambda _ (setenv "HOME" (string-append (getcwd) "/tmp")))))))
+ (lambda _ (setenv "HOME" (string-append (getcwd) "/tmp"))))
+ (replace 'check
+ (lambda _ (zero? (system* "nosetests" "-v")))))))
(native-inputs
`(("python2-beautifulsoup4" ,python2-beautifulsoup4)
("python2-flask" ,python2-flask)
("python2-setuptools" ,python2-setuptools)
("python2-mock" ,python2-mock)
("python2-mpd2" ,python2-mpd2)
+ ("python2-nose" ,python2-nose)
("python2-pathlib" ,python2-pathlib)
("python2-pyxdg" ,python2-pyxdg)
("python2-pyechonest" ,python2-pyechonest)
@@ -1301,3 +1308,33 @@ once and for all. It catalogs your collection, automatically improving its
metadata as it goes using the MusicBrainz database. Then it provides a variety
of tools for manipulating and accessing your music.")
(license license:expat)))
+
+(define-public milkytracker
+ (package
+ (name "milkytracker")
+ (version "0.90.86")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://milkytracker.org/files/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1v9vp8vi24lkagfpr92c128whvakwgrm9pq2zf6ijpl5sh7014zb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("CXXFLAGS=-lasound")))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("sdl" ,sdl)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Music tracker for working with .MOD/.XM module files")
+ (description "MilkyTracker is a music application for creating .MOD and .XM
+module files. It attempts to recreate the module replay and user experience of
+the popular DOS program Fasttracker II, with special playback modes available
+for improved Amiga ProTracker 2/3 compatibility.")
+ (home-page "http://milkytracker.org/")
+ ;; 'src/milkyplay' is under Modified BSD, the rest is under GPL3 or later.
+ (license (list license:bsd-3 license:gpl3+))))