summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 50e5d11f8d..16e69840df 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2017, 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 nee <nee.git@hidamari.blue>
;;; Copyright © 2018 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -876,11 +876,6 @@ interface. It is implemented as a frontend to @code{klick}.")
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; no check target
- (native-inputs
- `(;; Use gcc-4.9 to work around an internal compiler error that happens
- ;; when using gcc-5.5.0. FIXME: Try removing this when the default
- ;; compiler is no longer gcc-5.5.0.
- ("gcc" ,gcc-4.9)))
(home-page "https://bitbucket.org/mpyne/game-music-emu")
(synopsis "Video game music file playback library")
(description
@@ -2284,7 +2279,7 @@ improves on support for JACK features, such as JACK MIDI.")
("libsndfile" ,libsndfile)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://linuxsampler.org/libgig/")
+ (home-page "https://linuxsampler.org/libgig/")
(synopsis "C++ library for working with Gigasampler (.gig) files")
(description
"Libgig is a C++ library for loading, modifying existing and creating new
@@ -2621,7 +2616,7 @@ tune-in sender list from @url{http://opml.radiotime.com}.")
(define-public pianobar
(package
(name "pianobar")
- (version "2016.06.02")
+ (version "2019.02.14")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2630,10 +2625,10 @@ tune-in sender list from @url{http://opml.radiotime.com}.")
(file-name (git-file-name name version))
(sha256
(base32
- "058fbdxp7n35hxwy3b8slfy4pb4n63cb173vfmywqa06wh1dv6f6"))))
+ "1bfabkj3m9kmhxl64w4azmi0xf7w52fmqfbw2ag28hbb5yy01k1m"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
+ `(#:tests? #f ; no tests
#:make-flags (list "CC=gcc" "CFLAGS=-std=c99"
(string-append "PREFIX=" %output))
#:phases (modify-phases %standard-phases
@@ -2643,10 +2638,10 @@ tune-in sender list from @url{http://opml.radiotime.com}.")
("curl" ,curl)
("libgcrypt" ,libgcrypt)
("json-c" ,json-c)
- ("ffmpeg" ,ffmpeg-3.4)))
+ ("ffmpeg" ,ffmpeg)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://6xq.net/projects/pianobar/")
+ (home-page "https://6xq.net/pianobar/")
(synopsis "Console-based pandora.com player")
(description "pianobar is a console-based music player for the
personalized online radio pandora.com. It has configurable keys for playing