summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d4aaecc1e2..b6d09d14d7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1023,14 +1023,6 @@ Guile.")
(%current-system))))
'("--disable-sse")
'()))
- #:phases
- (modify-phases %standard-phases
- (add-before
- 'configure 'set-flags
- (lambda _
- ;; Compile with C++11, required by libsigc++.
- (setenv "CXXFLAGS" "-std=c++11")
- #t)))
#:python ,python-2))
(inputs
`(("jack" ,jack-1)
@@ -2951,8 +2943,7 @@ with a number of bugfixes and changes to improve IT playback.")
(patches (search-patches "sooperlooper-build-with-wx-30.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CXXFLAGS=-std=gnu++11")
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'add-sigc++-includes
(lambda* (#:key inputs #:allow-other-keys)
@@ -2964,7 +2955,8 @@ with a number of bugfixes and changes to improve IT playback.")
sig "/lib/sigc++-2.0/include:"
xml "/include/libxml2/:"
cwd "/libs/pbd:"
- cwd "/libs/midi++")))
+ cwd "/libs/midi++:"
+ (or (getenv "CPATH") ""))))
(substitute* '("src/control_osc.hpp"
"src/gui/app_frame.hpp"
"src/gui/config_panel.hpp"