summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm54
1 files changed, 50 insertions, 4 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b6d09d14d7..db6c42f6b1 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1999,14 +1999,14 @@ browser.")
(define-public drumstick
(package
(name "drumstick")
- (version "1.1.2")
+ (version "1.1.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/drumstick/"
version "/drumstick-" version ".tar.bz2"))
(sha256
(base32
- "0kljqyqj7s1i2z52i24x7ail1bywn6dcxxfbad5c59drm8wv94bp"))))
+ "1n9wvg79yvkygrkc8xd8pgrd3d7hqmr7gh24dccf0px23lla9b3m"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no test target
@@ -2042,6 +2042,52 @@ multiplatform realtime MIDI I/O library is also provided with various output
backends, including ALSA, OSS, Network and FluidSynth.")
(license license:gpl2+)))
+(define-public vmpk
+ (package
+ (name "vmpk")
+ (version "0.7.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/vmpk/vmpk/"
+ version "/vmpk-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1i3hnvdgz46n4k5v0q4jhgh7nkh0s390ix4nqr69z0q3026yp0p6"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no test target
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-docbook
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "cmake_admin/CreateManpages.cmake"
+ (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/manpages/docbook.xsl")))
+ #t)))))
+ (inputs
+ `(("drumstick" ,drumstick)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qttools" ,qttools)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("libxslt" ,libxslt) ;for xsltproc
+ ("docbook-xsl" ,docbook-xsl)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://vmpk.sourceforge.net")
+ (synopsis "Virtual MIDI piano keyboard")
+ (description
+ "Virtual MIDI Piano Keyboard is a MIDI events generator and receiver. It
+doesn't produce any sound by itself, but can be used to drive a MIDI
+synthesizer (either hardware or software, internal or external). You can use
+the computer's keyboard to play MIDI notes, and also the mouse. You can use
+the Virtual MIDI Piano Keyboard to display the played MIDI notes from another
+instrument or MIDI file player.")
+ (license license:gpl3+)))
+
(define-public zynaddsubfx
(package
(name "zynaddsubfx")
@@ -2091,7 +2137,7 @@ capabilities, custom envelopes, effects, etc.")
(define-public yoshimi
(package
(name "yoshimi")
- (version "1.5.10.2")
+ (version "1.6.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/yoshimi/"
@@ -2099,7 +2145,7 @@ capabilities, custom envelopes, effects, etc.")
"/yoshimi-" version ".tar.bz2"))
(sha256
(base32
- "1rr99qkq80s8l2iv3x4ccxan07m15dvmd5s9b10386bfjbwbya01"))))
+ "0bcc5spnq73yp1fmm367d1mxcswqkmzs3cnpb4cxr513ir98sa50"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are no tests