summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7ae0d9a36f..99778024ba 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2577,9 +2577,12 @@ Songs can be searched by artist, name or even by a part of the song text.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-HOME
- (lambda _ (setenv "HOME" (string-append (getcwd) "/tmp"))))
+ (lambda _
+ (setenv "HOME" (string-append (getcwd) "/tmp"))
+ #t))
(replace 'check
- (lambda _ (zero? (system* "nosetests" "-v")))))))
+ (lambda _
+ (invoke "nosetests" "-v"))))))
(native-inputs
`(("python-beautifulsoup4" ,python-beautifulsoup4)
("python-flask" ,python-flask)