summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e378e9880b..3ef04d7202 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2019 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -2213,7 +2213,7 @@ capabilities, custom envelopes, effects, etc.")
(define-public yoshimi
(package
(name "yoshimi")
- (version "1.6.1")
+ (version "1.7.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/yoshimi/"
@@ -2221,7 +2221,7 @@ capabilities, custom envelopes, effects, etc.")
"/yoshimi-" version ".tar.bz2"))
(sha256
(base32
- "1shnz429zgl0b4y5bpb61frk1747jwqfahq4hx44c972580zghzh"))))
+ "1pkqrrr51vlxh96vy0c0rf5ijjvymys4brsw9rv1bdp1bb8izw6c"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are no tests
@@ -5142,7 +5142,7 @@ and as an LV2 plugin.")
(define-public zrythm
(package
(name "zrythm")
- (version "0.7.345")
+ (version "0.7.474")
(source
(origin
(method url-fetch)
@@ -5150,13 +5150,21 @@ and as an LV2 plugin.")
version ".tar.xz"))
(sha256
(base32
- "1csiwq38a1ckx23lairfpl7qjkz71wsa7a9vsxl3k58f9ybibiil"))))
+ "0qq9v8y27zhamcb7nq7pl76874ws8x8cxhp5r685b8binvl9p0az"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
#:configure-flags
`("-Denable_tests=true" "-Dmanpage=true"
- "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")))
+ "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-xdg-open
+ (lambda _
+ (substitute* "src/utils/io.c"
+ (("OPEN_DIR_CMD")
+ (string-append "\"" (which "xdg-open") "\"")))
+ #t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("jack" ,jack-1)