summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9ee5206b33..1c0a4f3982 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1315,16 +1315,16 @@ Editor. It is compatible with Power Tab Editor 1.7 and Guitar Pro.")
(define-public jalv-select
(package
(name "jalv-select")
- (version "0.8")
+ (version "1.3")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/brummer10/jalv_select.git")
- (commit (string-append "V" version))))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0gqh768sbvn9ffyx1vqg9i57py9x9v4l65bk6wjsvgga4d7m83k1"))))
+ "15yanq1wra0hyh6x72ji7pk562iddg476g3vksj495x91zhnl6vm"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -1337,8 +1337,6 @@ Editor. It is compatible with Power Tab Editor 1.7 and Guitar Pro.")
(substitute* "jalv.select.cpp"
(("echo \\$PATH.*tr ':'.*xargs ls")
(string-append "ls -1 " (assoc-ref inputs "jalv") "/bin")))
- (substitute* "jalv.select.h"
- (("gtkmm.h") "gtkmm-2.4/gtkmm.h"))
#t))
(add-before 'reset-gzip-timestamps 'make-manpages-writable
(lambda* (#:key outputs #:allow-other-keys)
@@ -3727,7 +3725,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(define-public musescore
(package
(name "musescore")
- (version "3.0.5")
+ (version "3.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3736,7 +3734,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(file-name (git-file-name name version))
(sha256
(base32
- "1inf6zdyh6yspjv1i7g6rw9wn90vki1s2qgilkp0j4aphayj4mic"))
+ "07xkn8gnnqzhj9cn1li5qpm2rfm86bmxbbfd76i1jx4v999icn0j"))
(modules '((guix build utils)))
(snippet
;; Un-bundle OpenSSL and remove unused libraries.