summaryrefslogtreecommitdiff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm123
1 files changed, 123 insertions, 0 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
new file mode 100644
index 0000000000..b2c5dec15b
--- /dev/null
+++ b/gnu/packages/mpd.scm
@@ -0,0 +1,123 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages mpd)
+ #:use-module (srfi srfi-1)
+ #:use-module (gnu packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages avahi)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages mp3)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages sqlite)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages xiph)
+ #:export (libmpdclient
+ mpd))
+
+(define libmpdclient
+ (package
+ (name "libmpdclient")
+ (version "2.9")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://musicpd.org/download/libmpdclient/"
+ (car (string-split version #\.))
+ "/libmpdclient-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0csb9r3nlmbwpiryixjr5k33x3zqd61xjhwmlps3a6prck1n1xw2"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; FIXME: Needs doxygen.
+ '(#:configure-flags '("--disable-documentation")))
+ (synopsis "Music Player Daemon client library")
+ (description "A stable, documented, asynchronous API library for
+interfacing MPD in the C, C++ & Objective C languages.")
+ (home-page "http://www.musicpd.org/libs/libmpdclient/")
+ (license license:bsd-3)))
+
+(define mpd
+ (package
+ (name "mpd")
+ (version "0.18.8")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://musicpd.org/download/mpd/"
+ (string-join (take (string-split
+ version #\.) 2) ".")
+ "/mpd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ryqh0xf76xv4mpwy1gjwy275ar4wmbzifa9ccjim9r7lk2hgp5v"))))
+ (build-system gnu-build-system)
+ (inputs `(("ao" ,ao)
+ ("alsa-lib" ,alsa-lib)
+ ("avahi" ,avahi)
+ ("curl" ,curl)
+ ("ffmpeg" ,ffmpeg)
+ ("flac" ,flac)
+ ("glib" ,glib)
+ ("lame" ,lame)
+ ("libid3tag" ,libid3tag)
+ ("libmad" ,libmad)
+ ("libmpdclient" ,libmpdclient)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("libvorbis" ,libvorbis)
+ ("opus" ,opus)
+ ("pkg-config" ,pkg-config)
+ ("pulseaudio" ,pulseaudio)
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ ;; Missing optional inputs:
+ ;; libyajl
+ ;; libcdio_paranoia
+ ;; libmms
+ ;; libadplug
+ ;; libaudiofile
+ ;; faad2
+ ;; fluidsynth
+ ;; libgme
+ ;; libshout
+ ;; libmpg123
+ ;; libmodplug
+ ;; libmpcdec
+ ;; libsidplay2
+ ;; libwavpack
+ ;; libwildmidi
+ ;; libtwolame
+ ;; libroar
+ ;; libjack
+ ;; OpenAL
+ (synopsis "Music Player Daemon")
+ (description "Music Player Daemon (MPD) is a flexible, powerful,
+server-side application for playing music. Through plugins and libraries it
+can play a variety of sound files while being controlled by its network
+protocol.")
+ (home-page "http://www.musicpd.org/")
+ (license license:gpl2)))