summaryrefslogtreecommitdiff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 7b77c11835..5231c3f7f7 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -74,7 +74,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
(define-public mpd
(package
(name "mpd")
- (version "0.19.19")
+ (version "0.19.21")
(source (origin
(method url-fetch)
(uri
@@ -83,8 +83,19 @@ interfacing MPD in the C, C++ & Objective C languages.")
"/mpd-" version ".tar.xz"))
(sha256
(base32
- "07af1m2lgblyiq0gcs26zv8n22wrhrpmf49xsm338h1n87d6r1dw"))))
+ "0c0p61p3jfh89pnqwd9nrw55krfvvnzhkpdq53g6njvg0aybh1c3"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-service-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (systemd (string-append out "/etc/systemd/system"))
+ (systemd-user (string-append out "/etc/systemd/user")))
+ (install-file "systemd/system/mpd.service" systemd)
+ (install-file "systemd/user/mpd.service" systemd-user)
+ #t))))))
(inputs `(("ao" ,ao)
("alsa-lib" ,alsa-lib)
("avahi" ,avahi)