summaryrefslogtreecommitdiff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm33
1 files changed, 4 insertions, 29 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index fafb61c681..57ecef4913 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -33,7 +33,6 @@
#:use-module (guix build-system python)
#:use-module (gnu packages avahi)
#:use-module (gnu packages boost)
- #:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
@@ -103,17 +102,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
"0iknnm9xvwfgk8h82hjwrmbijpk9l0dgap0794c2nyg8i66qlb0y"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Ddocumentation=true") ; the default is 'false'...
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'expand-C++-include-path
- ;; Make <gcc>/include/c++/ext/string_conversions.h find <stdlib.h>.
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((path "CPLUS_INCLUDE_PATH")
- (gcc (assoc-ref inputs "gcc"))
- (c++ (string-append gcc "/include/c++")))
- (setenv path (string-append c++ ":" (getenv path)))
- #t))))))
+ `(#:configure-flags '("-Ddocumentation=true"))) ;the default is 'false'...
(inputs `(("ao" ,ao)
("alsa-lib" ,alsa-lib)
("avahi" ,avahi)
@@ -135,10 +124,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
("pulseaudio" ,pulseaudio)
("sqlite" ,sqlite)
("zlib" ,zlib)))
- ;; MPD > 0.21 requires > GCC 6
- (native-inputs `(("gcc" ,gcc-8)
- ("gcc-lib" ,gcc-8 "lib")
- ("pkg-config" ,pkg-config)
+ (native-inputs `(("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx)))
;; Missing optional inputs:
;; libyajl
@@ -211,19 +197,8 @@ player daemon.")
;; Otherwise, they are installed incorrectly, in
;; '$out/share/man/man/man1'.
(list (string-append "-Dmandir=" (assoc-ref %outputs "out")
- "/share"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'expand-C++-include-path
- ;; Make <gcc>/include/c++/ext/string_conversions.h find <stdlib.h>.
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((path "CPLUS_INCLUDE_PATH")
- (gcc (assoc-ref inputs "gcc"))
- (c++ (string-append gcc "/include/c++")))
- (setenv path (string-append c++ ":" (getenv path)))
- #t))))))
- (inputs `(("gcc" ,gcc-8) ; for its C++14 support
- ("boost" ,boost)
+ "/share"))))
+ (inputs `(("boost" ,boost)
("pcre" ,pcre)
("libmpdclient" ,libmpdclient)
("ncurses" ,ncurses)))