summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm49
1 files changed, 47 insertions, 2 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index da2c76b275..1930eb63aa 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -266,6 +266,51 @@ access to servers running the Discord protocol.")
(home-page "https://github.com/sm00th/bitlbee-discord/")
(license license:gpl2+)))
+(define-public purple-mattermost
+ (package
+ (name "purple-mattermost")
+ (version "1.2")
+ (home-page "https://github.com/EionRobb/purple-mattermost")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fm49iv58l09qpy8vkca3am642fxiwcrrh6ykimyc2mas210b5g2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Adjust the makefile to install files in the right
+ ;; place.
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("MATTERMOST_DEST = .*")
+ (string-append "MATTERMOST_DEST = " out
+ "/lib/purple-2\n")) ;XXX: hardcoded
+ (("MATTERMOST_ICONS_DEST = .*")
+ (string-append "MATTERMOST_ICONS_DEST = "
+ out
+ "/share/pixmaps/pidgin/protocols\n")))
+ #t))))
+ #:make-flags (list "CC=gcc"
+ ,(string-append "PLUGIN_VERSION=" version))
+ #:tests? #f))
+ (inputs `(("glib" ,glib)
+ ("json-glib" ,json-glib)
+ ("discount" ,discount)
+ ("pidgin" ,pidgin)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "Purple plug-in to access Mattermost instant messaging")
+ (description
+ "Purple-Mattermost is a plug-in for Purple, the instant messaging library
+used by Pidgin and Bitlbee, among others, to access
+@uref{https://mattermost.com/, Mattermost} servers.")
+ (license license:gpl3+)))
+
(define-public hexchat
(package
(name "hexchat")
@@ -505,14 +550,14 @@ compromised.")
(define-public znc
(package
(name "znc")
- (version "1.7.5")
+ (version "1.8.0")
(source (origin
(method url-fetch)
(uri (string-append "http://znc.in/releases/archive/znc-"
version ".tar.gz"))
(sha256
(base32
- "08a7yb2xs85hyyz8dpzfbsfjwj2r6kcii022lj3l4rf8hl9ix558"))))
+ "0m5xf60r40pgbg9lyk56dafxj2hj149pn2wf8vzsp8xgq4kv5zcl"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags