summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm196
1 files changed, 195 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 72b89067f0..8660915bb0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
+;;; Copyright © 2016 ng0 <ng0@libertad.pw>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;;
@@ -33,6 +33,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
+ #:use-module (guix build-system perl)
#:use-module (gnu packages)
#:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
@@ -43,11 +44,13 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages man)
#:use-module (gnu packages networking)
#:use-module (gnu packages libidn)
#:use-module (gnu packages lua)
@@ -57,6 +60,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages glib)
#:use-module (gnu packages python)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages tcl)
#:use-module (gnu packages compression)
@@ -67,8 +71,10 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages qt)
#:use-module (gnu packages video)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xiph)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages fontutils))
(define-public libotr
@@ -859,4 +865,192 @@ into existing applications.")
(home-page "https://camaya.net/gloox")
(license license:gpl3)))
+(define-public perl-net-psyc
+ (package
+ (name "perl-net-psyc")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://perlpsyc.psyc.eu/"
+ "perlpsyc-" version ".zip"))
+ (file-name (string-append name "-" version ".zip"))
+ (sha256
+ (base32
+ "1lw6807qrbmvzbrjn1rna1dhir2k70xpcjvyjn45y35hav333a42"))
+ ;; psycmp3 currently depends on MP3::List and rxaudio (shareware),
+ ;; we can add it back when this is no longer the case.
+ (snippet '(delete-file "contrib/psycmp3"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-curses" ,perl-curses)
+ ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; No configure script
+ ;; There is a Makefile, but it does not install everything
+ ;; (leaves out psycion) and says
+ ;; "# Just to give you a rough idea". XXX: Fix it upstream.
+ (replace 'build
+ (lambda _
+ (zero? (system* "make" "manuals"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/perl-net-psyc"))
+ (man1 (string-append out "/share/man/man1"))
+ (man3 (string-append out "/share/man/man3"))
+ (bin (string-append out "/bin"))
+ (libpsyc (string-append out "/lib/psyc/ion"))
+ (libperl (string-append out "/lib/perl5/site_perl/"
+ ,(package-version perl))))
+
+ (copy-recursively "lib/perl5" libperl)
+ (copy-recursively "lib/psycion" libpsyc)
+ (copy-recursively "bin" bin)
+ (install-file "cgi/psycpager" (string-append doc "/cgi"))
+ (copy-recursively "contrib" (string-append doc "/contrib"))
+ (copy-recursively "hooks" (string-append doc "/hooks"))
+ (copy-recursively "sdj" (string-append doc "/sdj"))
+ (install-file "README.txt" doc)
+ (install-file "TODO.txt" doc)
+ (copy-recursively "share/man/man1" man1)
+ (copy-recursively "share/man/man3" man3)
+ #t)))
+ (add-after 'install 'wrap-programs
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure all executables in "bin" find the Perl modules
+ ;; provided by this package at runtime.
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/"))
+ (path (getenv "PERL5LIB")))
+ (for-each (lambda (file)
+ (wrap-program file
+ `("PERL5LIB" ":" prefix (,path))))
+ (find-files bin "\\.*$"))
+ #t))))))
+ (description
+ "@code{Net::PSYC} with support for TCP, UDP, Event.pm, @code{IO::Select} and
+Gtk2 event loops. This package includes 12 applications and additional scripts:
+psycion (a @uref{http://about.psyc.eu,PSYC} chat client), remotor (a control console
+for @uref{https://torproject.org,tor} router) and many more.")
+ (synopsis "Perl implementation of PSYC protocol")
+ (home-page "http://perlpsyc.psyc.eu/")
+ (license (list license:gpl2
+ (package-license perl)
+ ;; contrib/irssi-psyc.pl:
+ license:public-domain
+ ;; bin/psycplay states AGPL with no version:
+ license:agpl3+))))
+
+(define-public libpsyc
+ (package
+ (name "libpsyc")
+ (version "20160913")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.psyced.org/files/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "14q89fxap05ajkfn20rnhc6b1h4i3i2adyr7y6hs5zqwb2lcmc1p"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)
+ ("netcat" ,netcat)
+ ("procps" ,procps)))
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; The rust bindings are the only ones in use, the lpc bindings
+ ;; are in psyclpc. The other bindings are not used by anything,
+ ;; the chances are high that the bindings do not even work,
+ ;; therefore we do not include them.
+ ;; TODO: Get a cargo build system in Guix.
+ (delete 'configure)))) ; no configure script
+ (home-page "http://about.psyc.eu/libpsyc")
+ (description
+ "@code{libpsyc} is a PSYC library in C which implements
+core aspects of PSYC, useful for all kinds of clients and servers
+including psyced.")
+ (synopsis "PSYC library in C")
+ (license license:agpl3+)))
+
+;; This commit removes the historic bundled pcre and makes psyclpc reproducible.
+(define-public psyclpc
+ (let* ((commit "61cf9aa81297085e5c40170fd01221c752f8deba")
+ (revision "2"))
+ (package
+ (name "psyclpc")
+ (version (string-append "20160821-" revision "." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.psyced.org/git/psyclpc")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1viwqymbhn3cwvx0zl58rlzl5gw47zxn0ldg2nbi55ghm5zxl1z5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests/checks.
+ #:configure-flags
+ ;; If you have questions about this part, look at
+ ;; "src/settings/psyced" and the ebuild.
+ (list
+ "--enable-use-tls=yes"
+ "--enable-use-mccp" ; Mud Client Compression Protocol, leave this enabled.
+ (string-append "--prefix="
+ (assoc-ref %outputs "out"))
+ ;; src/Makefile: Set MUD_LIB to the directory which contains
+ ;; the mud data. defaults to MUD_LIB = @libdir@
+ (string-append "--libdir="
+ (assoc-ref %outputs "out")
+ "/opt/psyced/world")
+ (string-append "--bindir="
+ (assoc-ref %outputs "out")
+ "/opt/psyced/bin")
+ ;; src/Makefile: Set ERQ_DIR to directory which contains the
+ ;; stuff which ERQ can execute (hopefully) savely. Was formerly
+ ;; defined in config.h. defaults to ERQ_DIR= @libexecdir@
+ (string-append "--libexecdir="
+ (assoc-ref %outputs "out")
+ "/opt/psyced/run"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'chdir-to-src
+ ;; We need to pass this as env variables
+ ;; and manually change the directory.
+ (lambda _
+ (chdir "src")
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (setenv "SHELL" (which "sh"))
+ #t)))
+ #:make-flags (list "install-all")))
+ (inputs
+ `(("zlib" ,zlib)
+ ("openssl" ,openssl)
+ ("pcre" ,pcre)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("bison" ,bison)
+ ("gettext" ,gettext-minimal)
+ ("help2man" ,help2man)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (home-page "http://lpc.psyc.eu/")
+ (synopsis "psycLPC is a multi-user network server programming language")
+ (description
+ "LPC is a bytecode language, invented to specifically implement
+multi user virtual environments on the internet. This technology is used for
+MUDs and also the psyced implementation of the Protocol for SYnchronous
+Conferencing (PSYC). psycLPC is a fork of LDMud with some new features and
+many bug fixes.")
+ (license license:gpl2))))
+
;;; messaging.scm ends here