summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm65
1 files changed, 33 insertions, 32 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 741b3285e2..f890ad8dd5 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1615,39 +1616,39 @@ are both supported).")
(license (list license:gpl3+ license:x11))))
(define-public profanity
- (package
- (name "profanity")
- (version "0.5.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.profanity.im/profanity-"
- version ".tar.gz"))
- (sha256
- (base32
- "1f7ylw3mhhnii52mmk40hyc4kqhpvjdr3hmsplzkdhsfww9kflg3"))))
- (build-system gnu-build-system)
- (inputs
- `(("curl" ,curl)
- ("expat" ,expat)
- ("glib" ,glib)
- ("gpgme" ,gpgme)
- ("libmesode" ,libmesode)
- ("libotr" ,libotr)
- ("ncurses" ,ncurses)
- ("openssl" ,openssl)
- ("readline" ,readline)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("autoconf-archive" ,autoconf-archive)
- ("automake" ,automake)
- ("cmocka" ,cmocka)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
- (synopsis "Console-based XMPP client")
- (description "Profanity is a console based XMPP client written in C
+ (package
+ (name "profanity")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://profanity-im.github.io/profanity-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nxh81j8ky0fzv47pip1jb7rs5rrin3jx0f3h632bvpjiya45r1z"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("expat" ,expat)
+ ("glib" ,glib)
+ ("gpgme" ,gpgme)
+ ("libmesode" ,libmesode)
+ ("libotr" ,libotr)
+ ("ncurses" ,ncurses)
+ ("openssl" ,openssl)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("cmocka" ,cmocka)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Console-based XMPP client")
+ (description "Profanity is a console based XMPP client written in C
using ncurses and libmesode, inspired by Irssi.")
- (home-page "http://www.profanity.im")
- (license license:gpl3+)))
+ (home-page "http://www.profanity.im")
+ (license license:gpl3+)))
(define-public libircclient
(package