summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm35
1 files changed, 32 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4ff7143f86..ccbb57b90f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages compression)
#:use-module ((gnu packages gettext)
#:renamer (symbol-prefix-proc 'gnu:))
+ #:use-module (gnu packages multiprecision)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages readline)
@@ -55,7 +56,7 @@ enough to be used effectively as a scientific calculator.")
(define-public gsl
(package
(name "gsl")
- (version "1.15")
+ (version "1.16")
(source
(origin
(method url-fetch)
@@ -63,10 +64,11 @@ enough to be used effectively as a scientific calculator.")
version ".tar.gz"))
(sha256
(base32
- "18qf6jzz1r3mzb5qynywv4xx3z9g61hgkbpkdrhbgqh2g7jhgfc5"))))
+ "0lrgipi0z6559jqh82yx8n4xgnxkhzj46v96dl77hahdp58jzg3k"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:parallel-tests? #f
+ #:phases
(alist-replace
'configure
(lambda* (#:key target system outputs #:allow-other-keys #:rest args)
@@ -88,6 +90,33 @@ differential equations, linear algebra, Fast Fourier Transforms and random
numbers.")
(license license:gpl3+)))
+(define-public glpk
+ (package
+ (name "glpk")
+ (version "4.52.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/glpk/glpk-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nz9ngmx23c8gbjr8l8ygnfaanxj2mwbl8awpg630bgrkxdnhc9j"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gmp" ,gmp)))
+ (arguments
+ `(#:configure-flags '("--with-gmp")))
+ (home-page "http://www.gnu.org/software/glpk/")
+ (synopsis "NU Linear Programming Kit, supporting the MathProg language")
+ (description
+ "GLPK is a C library for solving large-scale linear programming (LP),
+mixed integer programming (MIP), and other related problems. It supports the
+GNU MathProg modeling language, a subset of the AMPL language, and features a
+translator for the language. In addition to the C library, a stand-alone
+LP/MIP solver is included in the package.")
+ (license license:gpl3+)))
+
(define-public pspp
(package
(name "pspp")