summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cab84a520b..0d11f4695e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -377,15 +377,14 @@ semiconductors.")
(define-public gsl
(package
(name "gsl")
- (version "2.5")
+ (version "2.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gsl/gsl-"
version ".tar.gz"))
(sha256
(base32
- "1395y9hlhqadn5g9j8q22224fds5sd92jxi9czfavjj24myasq04"))
- (patches (search-patches "gsl-test-i686.patch"))))
+ "1a460zj9xmbgvcymkdhqh313c4l29mn9cffbi5vf33x3qygk70mp"))))
(build-system gnu-build-system)
(arguments
`(;; Currently there are numerous tests that fail on "exotic"
@@ -773,7 +772,7 @@ computations.")
("flex" ,flex)))
(inputs
`(("zlib" ,zlib)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libtirpc" ,libtirpc)))
(arguments
`(#:parallel-tests? #f
@@ -1013,7 +1012,7 @@ extremely large and complex data collections.")
`(("hdf4" ,hdf4)
("hdf5" ,hdf5)
("zlib" ,zlib)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("slf4j-api" ,java-slf4j-api)))
(arguments
`(#:configure-flags
@@ -1130,7 +1129,7 @@ implemented in C.")
`(("hdf4" ,hdf4-alt) ; assume most HDF-EOS2 users won't use the HDF4 netCDF API
;; XXX: These inputs are really dependencies of hdf4.
("zlib" ,zlib)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libtirpc" ,libtirpc)
("gctp" ,gctp)))
@@ -1290,7 +1289,7 @@ similar to MATLAB, GNU Octave or SciPy.")
`(("hdf4" ,hdf4-alt)
("hdf5" ,hdf5)
("zlib" ,zlib)
- ("libjpeg" ,libjpeg)))
+ ("libjpeg" ,libjpeg-turbo)))
(arguments
`(#:configure-flags '("--enable-doxygen" "--enable-dot" "--enable-hdf4")
@@ -3152,7 +3151,7 @@ parts of it.")
(define-public openblas
(package
(name "openblas")
- (version "0.3.7")
+ (version "0.3.8")
(source
(origin
(method url-fetch)
@@ -3161,7 +3160,7 @@ parts of it.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0jbdjsi0qsxahdcm42agnn1y7xpmg0hrhwjsxg0zbhs9wwy3p568"))))
+ "0f7n911vlriphlr4dgfdxk2x4lmjpf8kcl8w9lb584w2nwfkbdk9"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"