summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm21
1 files changed, 5 insertions, 16 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bce6627379..02c0e6988f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -464,12 +464,6 @@ large scale eigenvalue problems.")
("python" ,python-2)))
(arguments
`(#:configure-flags (list
- ;; Install to PREFIX/lib (the default is
- ;; PREFIX/lib64).
- (string-append "-DCMAKE_INSTALL_LIBDIR="
- (assoc-ref %outputs "out")
- "/lib")
-
"-DBUILD_SHARED_LIBS:BOOL=YES"
"-DLAPACKE=ON"
@@ -1963,8 +1957,7 @@ void mc64ad_ (int *a, int *b, int *c, int *d, int *e, double *f, int *g,
(arguments
`(#:configure-flags '("-Denable_blaslib:BOOL=NO" ;do not use internal cblas
"-DTPL_BLAS_LIBRARIES=openblas"
- "-DBUILD_SHARED_LIBS:BOOL=YES"
- "-DCMAKE_INSTALL_LIBDIR=lib")))
+ "-DBUILD_SHARED_LIBS:BOOL=YES")))
(home-page "http://crd-legacy.lbl.gov/~xiaoye/SuperLU/")
(synopsis "Supernodal direct solver for sparse linear systems")
(description
@@ -2617,7 +2610,7 @@ parts of it.")
(define-public openblas
(package
(name "openblas")
- (version "0.2.19")
+ (version "0.2.20")
(source
(origin
(method url-fetch)
@@ -2626,10 +2619,10 @@ parts of it.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "071zqnmnxhh0c9phzyn3f198yxa0hjxda7016azdbq2056sm70w7"))))
+ "1bd03c5xni0bla0wg1wba841b36b0sg13sjja955kn5xzvy4i61a"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;no "check" target
+ `(#:test-target "test"
;; DYNAMIC_ARCH is only supported on x86. When it is disabled and no
;; TARGET is specified, OpenBLAS will tune itself to the build host, so
;; we need to disable substitutions.
@@ -3581,11 +3574,7 @@ as equations, scalars, vectors, and matrices.")
"-DINSTALL_PYTHON_BINDINGS=true"
(string-append "-DCMAKE_INSTALL_PYTHON_PKG_DIR="
%output
- "/lib/python2.7/site-packages")
- (string-append "-DCMAKE_INSTALL_LIBDIR="
- %output
- "/lib"))
-
+ "/lib/python2.7/site-packages"))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'bootstrap