summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm52
1 files changed, 16 insertions, 36 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0392096563..4ff7143f86 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -44,25 +44,11 @@
(build-system gnu-build-system)
(synopsis "Conversion between thousands of scales")
(description
- "GNU Units converts quantities expressed in various systems of
-measurement to their equivalents in other systems of measurement. Like
-many similar programs, it can handle multiplicative scale changes. It can
-also handle nonlinear conversions such as Fahrenheit to Celsius or wire
-gauge, and it can convert from and to sums of units, such as converting
-between meters and feet plus inches.
-
-Beyond simple unit conversions, GNU Units can be used as a general-purpose
-scientific calculator that keeps track of units in its calculations. You
-can form arbitrary complex mathematical expressions of dimensions including
-sums, products, quotients, powers, and even roots of dimensions. Thus you
-can ensure accuracy and dimensional consistency when working with long
-expressions that involve many different units that may combine in complex
-ways.
-
-The units are defined in an external data file. You can use the extensive
-data file that comes with this program, or you can provide your own data
-file to suit your needs. You can also use your own data file to supplement
-the standard data file.")
+ "Units is a program for converting measured quantities between units of
+measure. It can handle scale changes through adaptive usage of standard
+scale prefixes (i.e. micro-, kilo-, etc.). It can also handle nonlinear
+conversions such as Fahrenheit to Celcius. Its interpreter is powerful
+enough to be used effectively as a scientific calculator.")
(license license:gpl3+)
(home-page "http://www.gnu.org/software/units/")))
@@ -95,14 +81,11 @@ the standard data file.")
(home-page "http://www.gnu.org/software/gsl/")
(synopsis "Numerical library for C and C++")
(description
- "The GNU Scientific Library (GSL) is a numerical library for C
-and C++ programmers. It is free software under the GNU General
-Public License.
-
-The library provides a wide range of mathematical routines such
-as random number generators, special functions and least-squares
-fitting. There are over 1000 functions in total with an
-extensive test suite.")
+ "The GNU Scientific Library is a library for numerical analysis in C
+and C++. It includes a wide range of mathematical routines, with over 1000
+functions in total. Subject areas covered by the library include:
+differential equations, linear algebra, Fast Fourier Transforms and random
+numbers.")
(license license:gpl3+)))
(define-public pspp
@@ -134,13 +117,10 @@ extensive test suite.")
(home-page "http://www.gnu.org/software/pspp/")
(synopsis "Statistical analysis")
(description
- "PSPP is a program for statistical analysis of sampled data. It is a
-free replacement for the proprietary program SPSS, and appears very similar
-to it.
-
-PSPP can perform descriptive statistics, T-tests, anova, linear and logistic
-regression, cluster analysis, factor analysis, non-parametric tests and
-more. Its backend is designed to perform its analyses as fast as possible,
-regardless of the size of the input data. You can use PSPP with its
-graphical interface or the more traditional syntax commands.")
+ "PSPP is a statistical analysis program. It can perform descriptive
+statistics, T-tests, linear regression and non-parametric tests. It features
+both a graphical interface as well as command-line input. PSPP is designed to
+interoperate with Gnumeric, LibreOffice and OpenOffice. Data can be imported
+from spreadsheets, text files and database sources and it can be output in
+text, Postscript, PDF or HTML.")
(license license:gpl3+)))