summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm35
1 files changed, 33 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a2bf14ea84..2b21e839a6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -25,6 +25,8 @@
;;; Copyright © 2018 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Nadya Voronova <voronovank@gmail.com>
+;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +55,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system ocaml)
+ #:use-module (guix build-system python)
#:use-module (guix build-system r)
#:use-module (guix build-system ruby)
#:use-module (gnu packages algebra)
@@ -564,7 +567,7 @@ singular value problems.")
(define-public gnuplot
(package
(name "gnuplot")
- (version "5.0.6")
+ (version "5.2.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
@@ -572,7 +575,7 @@ singular value problems.")
version ".tar.gz"))
(sha256
(base32
- "0q5lr6nala3ln6f3yp6g17ziymb9r9gx9zylnw1y3hjmwl9lggjv"))))
+ "18diyy7aib9mn098x07g25c7jij1x7wbfpicz0z8gwxx08px45m4"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)
("cairo" ,cairo)
@@ -582,6 +585,9 @@ singular value problems.")
(native-inputs
`(("pkg-config" ,pkg-config)
("texlive" ,texlive-tiny)))
+ (arguments `(#:configure-flags (list (string-append
+ "--with-texdir=" %output
+ "/texmf-local/tex/latex/gnuplot"))))
(home-page "http://www.gnuplot.info")
(synopsis "Command-line driven graphing utility")
(description "Gnuplot is a portable command-line driven graphing
@@ -1677,6 +1683,31 @@ scientific applications modeled by partial differential equations.")
,@(delete "--with-mpi=0" ,cf)))))
(synopsis "Library to solve PDEs (with complex scalars and MPI support)")))
+
+(define-public python-kiwisolver
+ (package
+ (name "python-kiwisolver")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "kiwisolver" version))
+ (sha256
+ (base32
+ "0y22ci86znwwwfhbmvbgdfnbi6lv5gv2xkdlxvjw7lml43ayafyf"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/nucleic/kiwi")
+ (synopsis "Fast implementation of the Cassowary constraint solver")
+ (description
+ "Kiwi is an efficient C++ implementation of the Cassowary constraint
+solving algorithm. Kiwi has been designed from the ground up to be
+lightweight and fast. Kiwi ranges from 10x to 500x faster than the original
+Cassowary solver with typical use cases gaining a 40x improvement. Memory
+savings are consistently > 5x.")
+ (license license:bsd-3)))
+
+(define-public python2-kiwisolver
+ (package-with-python2 python-kiwisolver))
+
(define-public slepc
(package
(name "slepc")