summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c595103ac5..df8bad13e0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1463,30 +1463,30 @@ can solve two kinds of problems:
"11wwxpy2q1bhxs2v41bqn05i2sb0905cj1xil6mg8l4k2kka4cq6"))))
(build-system gnu-build-system)
(inputs
- `(("lapack" ,lapack)
- ("qhull" ,qhull)
- ("readline" ,readline)
- ("gl2ps" ,gl2ps)
- ("glpk" ,glpk)
+ `(("alsa-lib" ,alsa-lib)
+ ("arpack" ,arpack-ng)
+ ("curl" ,curl)
("fftw" ,fftw)
("fftwf" ,fftwf)
- ("arpack" ,arpack-ng)
- ("pcre" ,pcre)
("fltk" ,fltk)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
- ("hdf5" ,hdf5)
- ("libxft" ,libxft)
- ("mesa" ,mesa)
+ ("gl2ps" ,gl2ps)
+ ("glpk" ,glpk)
("glu" ,glu)
- ("zlib" ,zlib)
- ("curl" ,curl)
- ("texinfo" ,texinfo)
("graphicsmagick" ,graphicsmagick)
- ("suitesparse" ,suitesparse)
+ ("hdf5" ,hdf5)
+ ("lapack" ,lapack)
("libsndfile" ,libsndfile)
+ ("libxft" ,libxft)
+ ("mesa" ,mesa)
+ ("pcre" ,pcre)
("portaudio" ,portaudio)
- ("alsa-lib" ,alsa-lib)))
+ ("qhull" ,qhull)
+ ("readline" ,readline)
+ ("suitesparse" ,suitesparse)
+ ("texinfo" ,texinfo)
+ ("zlib" ,zlib)))
(native-inputs
`(("lzip" ,lzip)
("gfortran" ,gfortran)
@@ -3369,13 +3369,15 @@ packages.")
;; Use `sh', not `/bin/sh'.
(substitute* (find-files "." "Makefile|configure|SpewMakeInc\\.c")
(("/bin/sh")
- "sh"))))
+ "sh"))
+ #t))
;; Fix /bin/sh in generated make files.
(add-after 'configure 'fix-/bin/sh-in-generated-files
(lambda _
(substitute* (find-files "." "^[Mm]ake\\.inc.*")
(("/bin/sh")
- "sh"))))
+ "sh"))
+ #t))
;; ATLAS configure program does not accepts the default flags
;; passed by the 'gnu-build-system'.
(replace 'configure