summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm64
1 files changed, 52 insertions, 12 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index adebf09a32..d37897da20 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1,15 +1,16 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2014, 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
-;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module (guix build utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system r)
#:use-module (gnu packages algebra)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
@@ -78,6 +80,26 @@
#:use-module (gnu packages zip)
#:use-module (srfi srfi-1))
+(define-public c-graph
+ (package
+ (name "c-graph")
+ (version "2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/c-graph/c-graph-" version
+ ".tar.gz"))
+ (sha256 (base32
+ "1hlvpzrh7hzzf533diyfiabzskddi8zx92av9hwkjw3l46z7qv01"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("fortran" ,gfortran)))
+ (synopsis "Visualize and analyze convolution operations")
+ (description
+ "GNU C-Graph demonstrates the theory of convolution underlying
+engineering systems and signal analysis.")
+ (license license:gpl3+)
+ (home-page "http://www.gnu.org/software/c-graph/")))
+
(define-public units
(package
(name "units")
@@ -755,7 +777,7 @@ arising after the discretization of partial differential equations.")
(sha256
(base32
"1820jfp3mbl7n85765v5mp6p0gzqpgr4d2lrnhwj4gl7cwp5ndah"))
- (patches (list (search-patch "mumps-build-parallelism.patch")))))
+ (patches (search-patches "mumps-build-parallelism.patch"))))
(build-system gnu-build-system)
(inputs
`(("fortran" ,gfortran)
@@ -911,6 +933,24 @@ sparse system of linear equations A x = b using Guassian elimination.")
(inputs
(alist-delete "pt-scotch" (package-inputs mumps-openmpi)))))
+(define-public r-pracma
+ (package
+ (name "r-pracma")
+ (version "1.8.8")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "pracma" version))
+ (sha256
+ (base32 "0ans9l5rrb7a38gyi4qx4258sd5r5668vyrk02yzjpg9k3h8l165"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/pracma")
+ (synopsis "Practical numerical math functions")
+ (description "This package provides functions for numerical analysis and
+linear algebra, numerical optimization, differential equations, plus some
+special functions. It uses Matlab function names where appropriate to simplify
+porting.")
+ (license license:gpl3+)))
+
(define-public superlu
(package
(name "superlu")
@@ -1004,7 +1044,7 @@ also provides threshold-based ILU factorization preconditioners.")
"superlu_dist_" version ".tar.gz"))
(sha256
(base32 "1hnak09yxxp026blq8zhrl7685yip16svwngh1wysqxf8z48vzfj"))
- (patches (list (search-patch "superlu-dist-scotchmetis.patch")))))
+ (patches (search-patches "superlu-dist-scotchmetis.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("tcsh" ,tcsh)))
@@ -1105,8 +1145,8 @@ implemented in ANSI C, and MPI for communications.")
"scotch_" version ".tar.gz"))
(sha256
(base32 "1ir088mvrqggyqdkx9qfynmiaffqbyih5qfl5mga2nrlm1qlsgzm"))
- (patches (list (search-patch "scotch-test-threading.patch")
- (search-patch "pt-scotch-build-parallelism.patch")))))
+ (patches (search-patches "scotch-test-threading.patch"
+ "pt-scotch-build-parallelism.patch"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)
@@ -1331,7 +1371,7 @@ to BMP, JPEG or PNG image formats.")
(sha256
(base32
"0x1rk659sn3cq0n5c90848ilzr1gb1wf0072fl6jhkdq00qgh2s0"))
- (patches (list (search-patch "maxima-defsystem-mkdir.patch")))))
+ (patches (search-patches "maxima-defsystem-mkdir.patch"))))
(build-system gnu-build-system)
(inputs
`(("gcl" ,gcl)
@@ -1444,14 +1484,14 @@ full text searching.")
(define-public armadillo
(package
(name "armadillo")
- (version "6.400.3")
+ (version "6.700.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/arma/armadillo-"
version ".tar.gz"))
(sha256
(base32
- "0bsgrmldlx77w5x26n3axj1hg6iw6csyw0dwl1flrbdwl51f9701"))))
+ "0dsdjcps5l2nhg0455rrc708inffarzj7n435vj4sm9lxwf21wg9"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ;no test target
(inputs
@@ -1472,14 +1512,14 @@ associated functions (eg. contiguous and non-contiguous submatrix views).")
(define-public armadillo-for-rcpparmadillo
(package (inherit armadillo)
- (version "6.200.2")
+ (version "6.700.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/arma/armadillo-"
version ".tar.gz"))
(sha256
(base32
- "1f69rlqhnf2wv8khyn2a8vi6gx1i72qgfy8b9b760ssk85dcl763"))))))
+ "1vnhifa7d0aij3kv5bxf6m91d99h3y2fyj48jrx7jcvwyb1q5wwq"))))))
(define-public muparser
(package
@@ -1920,7 +1960,7 @@ revised simplex and the branch-and-bound methods.")
(sha256
(base32
"185jych0gdnpkjwxni7pd0dda149492zwq2457xdjg76bzj78mnp"))
- (patches (list (search-patch "dealii-p4est-interface.patch")))
+ (patches (search-patches "dealii-p4est-interface.patch"))
(modules '((guix build utils)))
(snippet
;; Remove bundled sources: UMFPACK, TBB, muParser, and boost