summaryrefslogtreecommitdiff
path: root/gnu/packages/mastodon.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mastodon.scm')
-rw-r--r--gnu/packages/mastodon.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index 028745f681..cd12f5a7fd 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -42,6 +42,12 @@
'(#:phases
(modify-phases %standard-phases
(delete 'check)
+ ;; see https://github.com/ihabunek/toot/issues/91
+ (add-after 'unpack 'dont-install-Makefile
+ (lambda _
+ (substitute* "setup.py"
+ (("data_files.*" all) ""))
+ #t))
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)