summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 3dab1325e9..a2f7b183d5 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -137,9 +137,11 @@
(snippet
;; For a rebuild of the Flex/Bison byproducts touched by the
;; patch above.
- '(for-each delete-file
- '("mh/mh_alias_lex.c"
- "libmailutils/cfg/parser.c")))))
+ '(begin
+ (for-each delete-file
+ '("mh/mh_alias_lex.c"
+ "libmailutils/cfg/parser.c"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -427,7 +429,8 @@ It adds a large amount of new and improved features to mutt.")
(let* ((base (basename prog-path))
(prog (which base)))
(string-append pre
- (or prog (error "not found: " base))))))))))))
+ (or prog (error "not found: " base))))))
+ #t))))))
(home-page "http://spruce.sourceforge.net/gmime/")
(synopsis "MIME message parser and creator library")
(description
@@ -1816,7 +1819,7 @@ in Perl.")
(mkdir-p bin)
(with-directory-excursion bin
(copy-file source "mb2md.gz")
- (system* (string-append gzip "/bin/gzip") "-d" "mb2md.gz")
+ (invoke (string-append gzip "/bin/gzip") "-d" "mb2md.gz")
(substitute* "mb2md"
(("#!/usr/bin/perl")
(string-append "#!/usr/bin/perl -I " perl5lib)))