summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm125
1 files changed, 124 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 47c15497d4..0be0929e92 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -46,19 +46,23 @@
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
#:use-module (gnu packages dejagnu)
+ #:use-module (gnu packages dns)
#:use-module (gnu packages emacs)
#:use-module (gnu packages enchant)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages gsasl)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages flex)
#:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages m4)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pcre)
@@ -81,7 +85,8 @@
#:use-module ((guix licenses)
#:select (gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 lgpl2.1+ lgpl3+
non-copyleft (expat . license:expat) bsd-3
- public-domain))
+ public-domain bsd-4 isc (openssl . license:openssl)
+ bsd-2))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -1541,3 +1546,121 @@ transfer protocols.")
(license (non-copyleft "file://LICENSE"
"See LICENSE in the distribution."))))
+(define-public opensmtpd
+ (package
+ (name "opensmtpd")
+ (version "5.9.2p1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.opensmtpd.org/archives/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07d7f1m5sxyz6mkk228rcm7fsf7350994ayvmhgph333q5rz48im"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("bdb" ,bdb)
+ ("libressl" ,libressl)
+ ("libevent" ,libevent)
+ ("libasr" ,libasr)
+ ("linux-pam" ,linux-pam)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("bison" ,bison)))
+ (arguments
+ `(#:configure-flags (list "--with-table-db" "--localstatedir=/var"
+ "--with-user-smtpd=smtpd" "--with-user-queue=smtpq"
+ "--with-group-queue=smtpq")
+ #:phases
+ (modify-phases %standard-phases
+ ;; OpenSMTPD provides a single utility smtpctl to control the daemon and
+ ;; the local submission subsystem. To accomodate systems that require
+ ;; historical interfaces such as sendmail, newaliases or makemap, the
+ ;; smtpctl utility can operate in compatibility mode if called with the
+ ;; historical name.
+ (add-after 'install 'install-compabilitymode
+ (lambda _
+ (let* ((out (assoc-ref %outputs "out"))
+ (sbin (string-append out "/sbin/")))
+ (for-each (lambda (cmd)
+ (symlink "smtpctl" (string-append sbin cmd)))
+ '("makemap" "sendmail" "send-mail"
+ "newaliases" "mailq")))
+ #t)))))
+ (synopsis "Lightweight SMTP daemon")
+ (description
+ "OpenSMTPD is an implementation of the server-side SMTP protocol, with
+some additional standard extensions. It allows ordinary machines to exchange
+e-mails with other systems speaking the SMTP protocol.")
+ (home-page "https://www.opensmtpd.org")
+ (license (list bsd-2 bsd-3 bsd-4 (non-copyleft "file://COPYING")
+ public-domain isc openssl))))
+
+(define-public opensmtpd-extras
+ (package
+ (name "opensmtpd-extras")
+ (version "5.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.opensmtpd.org/archives/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kld4hxgz792s0cb2gl7m2n618ikzqkj88w5dhaxdrxg4x2c4vdm"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libressl" ,libressl)
+ ("libevent" ,libevent)
+ ("libasr" ,libasr)
+ ("python-2" ,python-2)
+ ("opensmtpd" ,opensmtpd)
+ ("perl" ,perl)
+ ("lua" ,lua)
+ ("postgresql" ,postgresql)
+ ("sqlite" ,sqlite)
+ ("linux-pam" ,linux-pam)))
+ (native-inputs
+ `(("bison" ,bison)
+ ("pkg-config" ,pkg-config)
+ ("groff" ,groff)
+ ("automake" ,automake)
+ ("autoconf" ,autoconf)))
+ (arguments
+ `(;; We have to configure it like this because the default checks for for example
+ ;; python in /usr/local/bin, /usr/bin and fails otherwise.
+ #:configure-flags (list
+ "--with-filter-clamav" "--with-filter-dkim-signer"
+ "--with-filter-dnsbl" "--with-filter-lua"
+ "--with-filter-monkey" "--with-filter-pause"
+ "--with-filter-perl" "--with-filter-python"
+ "--with-filter-regex" "--with-filter-spamassassin"
+ "--with-filter-stub" "--with-filter-trace"
+ "--with-filter-void"
+
+ "--with-queue-null" "--with-queue-python"
+ "--with-queue-ram" "--with-queue-stub"
+
+ "--with-scheduler-python" "--with-scheduler-ram"
+ "--with-scheduler-stub"
+
+ "--with-table-ldap" ; "--with-table-mysql"
+ "--with-table-passwd" "--with-table-postgres"
+ "--with-table-python" "--with-table-socketmap"
+ "--with-table-sqlite" "--with-table-stub"
+ ;;"--with-table-redis" ; TODO: package hiredis
+
+ "--with-user=smtpd" "--with-privsep-user=smtpd"
+ "--localstatedir=/var" "--sysconfdir=/etc"
+ "--with-lua-type=lua" ; can use lua or luajit
+
+ (string-append "--with-python="
+ (assoc-ref %build-inputs "python-2"))
+ (string-append "--with-lua="
+ (assoc-ref %build-inputs "lua")))))
+ (license (list bsd-2 bsd-3 bsd-4 non-copyleft
+ public-domain isc openssl))
+ (synopsis "Extra tables, filters, and various other addons for OpenSMTPD")
+ (description
+ "This package provides extra tables, filters, and various other addons
+for OpenSMTPD to extend its functionality.")
+ (home-page "https://www.opensmtpd.org")))