aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 1164ba8cbb..bf70bd6013 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -162,6 +162,7 @@ toolkit. It allows users to monitor and control of running processes.")
(uri (string-append "mirror://sourceforge/lxde/LXTerminal"
"%20%28terminal%20emulator%29/LXTerminal%20"
version "/" name "-" version ".tar.xz"))
+ (patches (search-patches "lxterminal-CVE-2016-10369.patch"))
(sha256
(base32
"1yf76s15zvfw0h42b0ay1slpq47khgjmcry8ki2z812zar9lchia"))))
@@ -288,11 +289,26 @@ menu spec-compliant desktop menus for LXDE.")
(base32
"0mj84fa3f4ak1jjslrwc2q3ci9zxrxpciggviza9bjb0168brn8w"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-lxsession
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Set the right file name for 'lxsession'.
+ (let ((lxsession (assoc-ref inputs "lxsession")))
+ (substitute* "startlxde.in"
+ (("^exec .*/bin/lxsession")
+ (string-append "exec " lxsession
+ "/bin/lxsession")))
+ #t))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)
("lxmenu-data" ,lxmenu-data)
("lxde-icon-theme" ,lxde-icon-theme)))
+ (inputs
+ `(("lxsession" ,lxsession)
+ ;; ("lxlock" ,lxlock) ;for 'lxde-screenlock.desktop'
+ ))
(synopsis "Common files of the LXDE Desktop")
(description
"Lxde-common provides common files of the LXDE Desktop.")