summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm23
1 files changed, 2 insertions, 21 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index da3d079b24..d0a0065957 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3548,7 +3548,7 @@ client and server.")
(home-page "https://common-lisp.net/project/trivial-backtrace/")
(synopsis "Portable simple API to work with backtraces in Common Lisp")
(description
- "On of the many things that didn't quite get into the Common Lisp
+ "One of the many things that didn't quite get into the Common Lisp
standard was how to get a Lisp to output its call stack when something has
gone wrong. As such, each Lisp has developed its own notion of what to
display, how to display it, and what sort of arguments can be used to
@@ -5484,26 +5484,7 @@ and @code{kqueue(2)}), a pathname library and file-system utilities.")
(synopsis "Base package for IOLib, a Common Lisp I/O library")))
(define-public sbcl-iolib.grovel
- (package
- (inherit sbcl-iolib.asdf)
- (name "sbcl-iolib.grovel")
- (inputs
- `(("iolib.asdf" ,sbcl-iolib.asdf)
- ("iolib.conf" ,sbcl-iolib.conf)
- ("iolib.base", sbcl-iolib.base)
- ("cffi", sbcl-cffi)))
- (arguments
- '(#:asd-file "iolib.grovel.asd"
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-header
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This header is required by sbcl-iolib.
- (install-file "src/grovel/grovel-common.h"
- (string-append (assoc-ref outputs "out")
- "/lib/sbcl"))
- #t)))))
- (synopsis "CFFI Groveller for IOLib, a Common Lisp I/O library")))
+ (deprecated-package "sbcl-iolib.grovel" sbcl-cffi-grovel))
(define sbcl-iolib+syscalls
(package