summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c2029d940e..b032346a30 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11533,21 +11533,19 @@ MOP easier to use.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'validate-runpath 'cleanup-files
+ ;; The cleanup phase moves files around but we need to keep the
+ ;; directory structure for the grovel-generated library.
+ (replace 'cleanup
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib/sbcl")))
- (for-each
- delete-file
- (filter (lambda (file)
- (not (member (basename file)
- '("basic-unixint__grovel"
- "libosicat.so"
- "osicat--system.fasl"
- "osicat.asd"
- "unixint__grovel"))))
- (find-files lib ".*")))
- #t))))))
+ (lib (string-append out "/lib/sbcl/")))
+ (delete-file-recursively (string-append lib "src"))
+ (delete-file-recursively (string-append lib "tests"))
+ (for-each delete-file
+ (filter (lambda (file)
+ (not (member (basename file) '("libosicat.so"))))
+ (find-files (string-append lib "posix") ".*"))))
+ #t)))))
(inputs
`(("alexandria" ,sbcl-alexandria)
("cffi" ,sbcl-cffi)