summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm46
1 files changed, 41 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 469ccc552c..cd1c921626 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages attr)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages autotools)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -65,7 +66,7 @@
version "-gnu.tar.xz")))
(define-public linux-libre-headers
- (let* ((version* "3.3.8")
+ (let* ((version "3.3.8")
(build-phase
(lambda (arch)
`(lambda _
@@ -85,10 +86,10 @@
(string-append out
"/include/config/kernel.release")
(lambda (p)
- (format p "~a-default~%" ,version*))))))))
+ (format p "~a-default~%" ,version))))))))
(package
(name "linux-libre-headers")
- (version version*)
+ (version version)
(source (origin
(method url-fetch)
(uri (linux-libre-urls version))
@@ -145,7 +146,7 @@
(license gpl2+)))
(define-public linux-libre
- (let* ((version* "3.11")
+ (let* ((version "3.11")
(build-phase
'(lambda* (#:key system #:allow-other-keys #:rest args)
(let ((arch (car (string-split system #\-))))
@@ -185,7 +186,7 @@
"modules_install"))))))
(package
(name "linux-libre")
- (version version*)
+ (version version)
(source (origin
(method url-fetch)
(uri (linux-libre-urls version))
@@ -719,3 +720,38 @@ Linux-based operating systems.")
;; License is BSD-3 or GPLv2, at the user's choice.
(license gpl2)))
+
+(define-public bridge-utils
+ (package
+ (name "bridge-utils")
+ (version "1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/bridge/bridge-utils-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12367cwqmi0yqphi6j8rkx97q8hw52yq2fx4k0xfclkcizxybya2"))))
+ (build-system gnu-build-system)
+
+ ;; The tarball lacks all the generated files.
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (arguments
+ '(#:phases (alist-cons-before
+ 'configure 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vf")))
+ %standard-phases)
+ #:tests? #f)) ; no 'check' target
+
+ (home-page
+ "http://www.linuxfoundation.org/collaborate/workgroups/networking/bridge")
+ (synopsis "Manipulate Ethernet bridges")
+ (description
+ "Utilities for Linux's Ethernet bridging facilities. A bridge is a way
+to connect two Ethernet segments together in a protocol independent way.
+Packets are forwarded based on Ethernet address, rather than IP address (like
+a router). Since forwarding is done at Layer 2, all protocols can go
+transparently through a bridge.")
+ (license gpl2+)))