summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3f1603709c..9020a599e2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -309,10 +309,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
("flex" ,flex)
("bison" ,bison)
- ;; Build with GCC-7 for full retpoline support.
- ;; FIXME: Remove this when our default compiler has retpoline support.
- ("gcc" ,gcc-7)
-
;; These are needed to compile the GCC plugins.
("gmp" ,gmp)
("mpfr" ,mpfr)
@@ -339,11 +335,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(substitute* (find-files "." "^Makefile(\\.include)?$")
(("/bin/pwd") "pwd"))
#t))
- (add-before 'configure 'work-around-gcc-7-include-path-issue
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
(replace 'configure
(lambda* (#:key inputs native-inputs target #:allow-other-keys)
;; Avoid introducing timestamps
@@ -1391,7 +1382,7 @@ configuration (iptunnel, ipmaddr).")
(define-public libcap
(package
(name "libcap")
- (version "2.25")
+ (version "2.26")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1399,7 +1390,7 @@ configuration (iptunnel, ipmaddr).")
"libcap2/libcap-" version ".tar.xz"))
(sha256
(base32
- "0qjiqc5pknaal57453nxcbz3mn1r4hkyywam41wfcglq3v2qlg39"))))
+ "12s5b8fp61jcn4qld8a7fakcz1han4a6l3b8cyl3n6r7hk2bfc5n"))))
(build-system gnu-build-system)
(arguments '(#:phases
(modify-phases %standard-phases
@@ -4149,7 +4140,14 @@ under OpenGL graphics workloads.")
(string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
#:phases
(modify-phases %standard-phases
- (delete 'configure))))
+ (delete 'configure)
+ (add-before 'build 'kernel-headers-are-system-headers
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((kernel-headers (assoc-ref inputs "kernel-headers")))
+ ;; Make sure the kernel headers are treated as system headers
+ ;; to suppress a conflict between "util.h" and <linux/fs.h>.
+ (setenv "C_INCLUDE_PATH" (string-append kernel-headers "/include"))
+ #t))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -4182,7 +4180,12 @@ interface to the variable facility of UEFI boot firmware.")
;; installed (known as OS_VENDOR in the code).
;; GRUB overrides this, as such it's only used if
;; nothing else is specified on the command line.
- "EFIDIR=gnu")
+ "EFIDIR=gnu"
+ ;; Treat kernel headers as system headers to prevent
+ ;; warnings about conflicting types.
+ (string-append "C_INCLUDE_PATH="
+ (assoc-ref %build-inputs "kernel-headers")
+ "/include"))
#:phases (modify-phases %standard-phases (delete 'configure))))
(native-inputs
`(("pkg-config" ,pkg-config)))