summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm62
1 files changed, 36 insertions, 26 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c0c963ec55..d63d3ba925 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -383,8 +383,8 @@ It has been modified to remove all non-free binary blobs.")
;; supports qemu "virt" machine and possibly a large number of ARM boards.
;; See : https://wiki.debian.org/DebianKernel/ARMMP.
-(define %linux-libre-version "4.15.7")
-(define %linux-libre-hash "1h17wc12lvva5vcm2z06cf57ywxb6i2snm9vxixw1lwibnksrb6l")
+(define %linux-libre-version "4.15.10")
+(define %linux-libre-hash "10fp8jmy0fxq8l01m1nnagpq1hznl9jmhcwknk8izjmdcb5snq6c")
(define-public linux-libre
(make-linux-libre %linux-libre-version
@@ -392,8 +392,8 @@ It has been modified to remove all non-free binary blobs.")
%linux-compatible-systems
#:configuration-file kernel-config))
-(define %linux-libre-4.14-version "4.14.24")
-(define %linux-libre-4.14-hash "1i14djw3rmxb6syl6vfd5w76rjksbbaviynwj2dwwp9ki1h6p1hr")
+(define %linux-libre-4.14-version "4.14.27")
+(define %linux-libre-4.14-hash "0mgkka9niyd0lj4qliy4v7jjh9lg1a5jwlv60yw7z0s4k7ajyyrp")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
@@ -402,20 +402,20 @@ It has been modified to remove all non-free binary blobs.")
#:configuration-file kernel-config))
(define-public linux-libre-4.9
- (make-linux-libre "4.9.86"
- "0fqixx3yyvznianygk8bfxzfqj8zpnjcalifhpfyb7rm3dyvi3wd"
+ (make-linux-libre "4.9.87"
+ "1p8phvmxp04npzqzqcfmv8k9l5l65s7vpjcakdm0fxfkzvnswsp6"
%intel-compatible-systems
#:configuration-file kernel-config))
(define-public linux-libre-4.4
- (make-linux-libre "4.4.120"
- "17zk5dbpa3kilf8m8i6r2jifjgi4yjim42gyk9j6n4218jjcszv6"
+ (make-linux-libre "4.4.121"
+ "1d7djrhiib0ds9ssjkali6b5w6rzap4zgj5hf9jq1jmqpp54jkm4"
%intel-compatible-systems
#:configuration-file kernel-config))
(define-public linux-libre-4.1
- (make-linux-libre "4.1.49"
- "0dklmqj6ayjlkz97b811zdvpgb3yppahinji9l9jmkz4ssi7a1gs"
+ (make-linux-libre "4.1.50"
+ "1hl1pk724v2waa55bhxfmxyz9nl6pkcj4dc3l80jfvqdfgr55mm2"
%intel-compatible-systems
#:configuration-file kernel-config))
@@ -547,6 +547,7 @@ providing the system administrator with some help in common tasks.")
(define-public util-linux
(package
(name "util-linux")
+ (replacement util-linux/fixed)
(version "2.31")
(source (origin
(method url-fetch)
@@ -634,6 +635,15 @@ block devices, UUIDs, TTYs, and many other tools.")
(license (list license:gpl3+ license:gpl2+ license:gpl2 license:lgpl2.0+
license:bsd-4 license:public-domain))))
+(define util-linux/fixed
+ (package
+ (inherit util-linux)
+ (source
+ (origin
+ (inherit (package-source util-linux))
+ (patches (append (origin-patches (package-source util-linux))
+ (search-patches "util-linux-CVE-2018-7738.patch")))))))
+
(define-public ddate
(package
(name "ddate")
@@ -1758,7 +1768,7 @@ file system is as easy as logging into the server with an SSH client.")
(define-public archivemount
(package
(name "archivemount")
- (version "0.8.7")
+ (version "0.8.9")
(source
(origin
(method url-fetch)
@@ -1766,11 +1776,11 @@ file system is as easy as logging into the server with an SSH client.")
"archivemount-" version ".tar.gz"))
(sha256
(base32
- "1diiw6pnlnrnikn6l5ld92dx59lhrxjlqms8885vwbynsjl5q127"))))
+ "0v4si1ri6lhnq9q87gkx7fsh6lv6xz4bynknwndqncpvfp5cy1jg"))))
(build-system gnu-build-system)
- (inputs `(("fuse", fuse)
- ("libarchive", libarchive)))
- (native-inputs `(("pkg-config", pkg-config)))
+ (inputs `(("fuse" ,fuse)
+ ("libarchive" ,libarchive)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
(home-page "http://www.cybernoia.de/software/archivemount")
(synopsis "Tool for mounting archive files with FUSE")
(description "archivemount is a FUSE-based file system for Unix variants,
@@ -2024,7 +2034,7 @@ from the module-init-tools project.")
("docbook-xml" ,docbook-xml-4.2)
("docbook-xsl" ,docbook-xsl)
("libxml2" ,libxml2) ;for $XML_CATALOG_FILES
- ("xsltproc", libxslt)))
+ ("xsltproc" ,libxslt)))
(inputs
;; When linked against libblkid, eudev can populate /dev/disk/by-label
;; and similar; it also installs the '60-persistent-storage.rules' file,
@@ -3394,8 +3404,8 @@ The package provides additional NTFS tools.")
;; Upstream uses the "ninja" build system and encourage distros
;; to do the same for consistency. They also recommend using the
;; "Release" build type.
- #:configure-flags (list "-GNinja"
- "-DCMAKE_BUILD_TYPE=Release")
+ #:build-type "Release"
+ #:configure-flags (list "-GNinja")
#:phases
(modify-phases %standard-phases
(replace 'build
@@ -3697,7 +3707,7 @@ are exceeded.")
(inputs
`(("acl" ,acl)
("libuuid" ,util-linux)
- ("lzo", lzo)
+ ("lzo" ,lzo)
("zlib" ,zlib)))
(build-system gnu-build-system)
(arguments
@@ -4127,13 +4137,13 @@ used by nftables.")
(base32
"1i1gfy8l7qyhc5vlrpp63s0n5kybmc9pi4dywiq8rmkhrrnddsla"))))
(build-system gnu-build-system)
- (inputs `(("bison", bison)
- ("flex", flex)
- ("gmp", gmp)
- ("libmnl", libmnl)
- ("libnftnl", libnftnl)
- ("readline", readline)))
- (native-inputs `(("pkg-config", pkg-config)))
+ (inputs `(("bison" ,bison)
+ ("flex" ,flex)
+ ("gmp" ,gmp)
+ ("libmnl" ,libmnl)
+ ("libnftnl" ,libnftnl)
+ ("readline" ,readline)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
(home-page "http://www.nftables.org")
(synopsis "Userspace utility for Linux packet filtering")
(description "nftables is the project that aims to replace the existing