summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index a763b5f95c..1faab302a0 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
-;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
@@ -705,12 +705,6 @@ Zoner Draw version 4 and 5.")
("libtool" ,libtool)))
(inputs
`(("perl" ,perl)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (invoke "autoreconf" "-vfi") #t)))))
(native-search-paths (list (search-path-specification
(variable "DICPATH")
(files '("share/hunspell")))))
@@ -752,8 +746,8 @@ word compounding or character encoding.")
(doc (string-append out "/share/doc/"
,name))
(unzip (assoc-ref %build-inputs "unzip")))
- (system* (string-append unzip "/bin/unzip")
- (assoc-ref %build-inputs "source"))
+ (invoke (string-append unzip "/bin/unzip")
+ (assoc-ref %build-inputs "source"))
(for-each (cut install-file <> hunspell)
(find-files "."
,(string-append variant