summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 799b062439..3c04ba8c49 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -946,6 +946,12 @@ and to return information on pronunciations, meanings and synonyms.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((xmlsec (assoc-ref inputs "xmlsec-src")))
(substitute*
+ "sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx"
+ ;; This header was renamed in Poppler 0.62.0.
+ (("UTF8.h") "UnicodeMapFuncs.h")
+ ;; And mapUCS2() was renamed to mapUTF16().
+ (("UCS2") "UTF16"))
+ (substitute*
(list "sysui/CustomTarget_share.mk"
"solenv/gbuild/gbuild.mk"
"solenv/gbuild/platform/unxgcc.mk")