summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index f9dc6099e1..a3a6ea5d1a 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -539,6 +539,17 @@ library primarily intended for language guessing.")
(sha256 (base32
"1b1lvqh68rwij1yvmxy02hsmh7i74ma5767mk8mg5nx6chajshhf"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'build 'adjust-for-ICU-65
+ (lambda _
+ ;; Fix build with ICU 65 and later. Taken from this
+ ;; upstream commit, remove for libfreehand > 0.1.2:
+ ;; https://gerrit.libreoffice.org/#/c/80224/
+ (substitute* "src/lib/libfreehand_utils.cpp"
+ (("U16_NEXT.*" all)
+ (string-append all ";\n")))
+ #t)))))
(native-inputs
`(("cppunit" ,cppunit)
("doxygen" ,doxygen)
@@ -995,6 +1006,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(string-append
"https://download.documentfoundation.org/libreoffice/src/"
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
+ (patches (search-patches "libreoffice-poppler-compat.patch"))
(sha256
(base32
"06acm41q9nda8r30b13cn9zafsw1gszjdphh6lx90s09d2sf7f23"))))