summaryrefslogtreecommitdiff
path: root/gnu/packages/libpng.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libpng.scm')
-rw-r--r--gnu/packages/libpng.scm52
1 files changed, 0 insertions, 52 deletions
diff --git a/gnu/packages/libpng.scm b/gnu/packages/libpng.scm
deleted file mode 100644
index 810645ea68..0000000000
--- a/gnu/packages/libpng.scm
+++ /dev/null
@@ -1,52 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages libpng)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public libpng
- (package
- (name "libpng")
- (version "1.5.17")
- (source (origin
- (method url-fetch)
-
- ;; Note: upstream removes older tarballs.
- (uri (list (string-append "mirror://sourceforge/libpng/libpng15/"
- version "/libpng-" version ".tar.xz")
- (string-append
- "ftp://ftp.simplesystems.org/pub/libpng/png/src"
- "/libpng15/libpng-" version ".tar.xz")))
- (sha256
- (base32 "19wj293r4plbfgb43yhrc2qx8bsch9gbazazfqrj9haa7lsk29jp"))))
- (build-system gnu-build-system)
-
- ;; libpng.la says "-lz", so propagate it.
- (propagated-inputs `(("zlib" ,zlib)))
-
- (synopsis "Library for handling PNG files")
- (description
- "Libpng is the official PNG (Portable Network Graphics) reference
-library. It supports almost all PNG features and is extensible.")
- (license license:zlib)
- (home-page "http://www.libpng.org/pub/png/libpng.html")))