summaryrefslogtreecommitdiff
path: root/gnu/packages/libjpeg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libjpeg.scm')
-rw-r--r--gnu/packages/libjpeg.scm56
1 files changed, 0 insertions, 56 deletions
diff --git a/gnu/packages/libjpeg.scm b/gnu/packages/libjpeg.scm
deleted file mode 100644
index 6415210097..0000000000
--- a/gnu/packages/libjpeg.scm
+++ /dev/null
@@ -1,56 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages libjpeg)
- #:use-module (gnu packages)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public libjpeg
- (package
- (name "libjpeg")
- (version "9")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.ijg.org/files/jpegsrc.v"
- version ".tar.gz"))
- (sha256 (base32
- "0dg5wxcx3cw0hal9gvivj97vid9z0s5sb1yvg55hpxmafn9rxqn4"))))
- (build-system gnu-build-system)
- (synopsis "Libjpeg, a library for handling JPEG files")
- (description
- "Libjpeg implements JPEG image encoding, decoding, and transcoding.
-JPEG is a standardized compression method for full-color and gray-scale
-images.
-The included programs provide conversion between the JPEG format and
-image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
- (license ijg)
- (home-page "http://www.ijg.org/")))
-
-(define-public libjpeg-8
- (package (inherit libjpeg)
- (version "8d")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.ijg.org/files/jpegsrc.v"
- version ".tar.gz"))
- (sha256 (base32
- "1cz0dy05mgxqdgjf52p54yxpyy95rgl30cnazdrfmw7hfca9n0h0"))))))
-