summaryrefslogtreecommitdiff
path: root/gnu/packages/libidn.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libidn.scm')
-rw-r--r--gnu/packages/libidn.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/libidn.scm b/gnu/packages/libidn.scm
index dfb1be6c4f..c2290b53af 100644
--- a/gnu/packages/libidn.scm
+++ b/gnu/packages/libidn.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,7 +39,17 @@
".tar.gz"))
(sha256
(base32
- "068fjg2arlppjqqpzd714n1lf6gxkpac9v5yyvp1qwmv6nvam9s4"))))
+ "068fjg2arlppjqqpzd714n1lf6gxkpac9v5yyvp1qwmv6nvam9s4"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; The gnulib test-lock test is prone to writer starvation
+ ;; with our glibc@2.25, which prefers readers, so disable it.
+ ;; The gnulib commit b20e8afb0b2 should fix this once
+ ;; incorporated here.
+ (substitute* "lib/gltests/Makefile.in"
+ (("test-lock\\$\\(EXEEXT\\) ") ""))
+ #t))))
(build-system gnu-build-system)
;; FIXME: No Java and C# libraries are currently built.
(synopsis "Internationalized string processing library")
@@ -55,15 +66,14 @@ Java libraries.")
(define-public libidn2
(package
(name "libidn2")
- (version "2.0.2")
- (replacement libidn2-2.0.4)
+ (version "2.0.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libidn/" name "-" version
".tar.lz"))
(sha256
(base32
- "0pqaj8d01aj4i110669fincqs10kgynyqcrmq2q7pss8v9dcd1jq"))))
+ "00f2fyw5kwr9is3cdn5h9arzxp0lnvg0z9bb9zyfs0dq81gaqim4"))))
(native-inputs
`(("lzip" ,lzip)))
(inputs
@@ -75,19 +85,7 @@ the IDNA2008 specifications. Libidn2 is believed to be a complete IDNA2008
implementation, but has yet to be as extensively used as the original Libidn
library.")
(home-page "https://www.gnu.org/software/libidn/#libidn2")
+ (properties '((ftp-directory . "/gnu/libidn")))
;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
;; GPL2+ or LGPL3+.
(license (list gpl2+ gpl3+ lgpl3+))))
-
-(define-public libidn2-2.0.4
- (package
- (inherit libidn2)
- (name "libidn2")
- (version "2.0.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/libidn/" name "-" version
- ".tar.lz"))
- (sha256
- (base32
- "00f2fyw5kwr9is3cdn5h9arzxp0lnvg0z9bb9zyfs0dq81gaqim4"))))))