summaryrefslogtreecommitdiff
path: root/gnu/packages/lego.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lego.scm')
-rw-r--r--gnu/packages/lego.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/lego.scm b/gnu/packages/lego.scm
index d5e5de1c1f..3203e1c9b4 100644
--- a/gnu/packages/lego.scm
+++ b/gnu/packages/lego.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,7 +73,7 @@ restrictions that stem from limitations of the standard RCX firmware.")
(define-public leocad
(package
(name "leocad")
- (version "17.07")
+ (version "18.02")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/leozide/leocad/"
@@ -80,10 +81,10 @@ restrictions that stem from limitations of the standard RCX firmware.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "02gm4950zlmsw4sxmdwypgkybn51b02qnmmk6rzjdr8si4k6gikq"))))
+ "189wj221fn08bnsfwy8050bxkjgjwinkn19qdcvb6c2ry2lnfra9"))))
(build-system gnu-build-system)
(native-inputs
- `(("qttools" ,qttools))) ;for lrelease
+ `(("qttools" ,qttools))) ; for lrelease
(inputs
`(("mesa" ,mesa)
("qtbase" ,qtbase)
@@ -95,12 +96,13 @@ restrictions that stem from limitations of the standard RCX firmware.")
(replace 'configure
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "qmake"
- (string-append "INSTALL_PREFIX=" out)
- ;; Otherwise looks for lrelease-qt4
- "QMAKE_LRELEASE=lrelease"
- ;; Don't pester users about updates
- "DISABLE_UPDATE_CHECK=1")))))
+ (invoke "qmake"
+ (string-append "INSTALL_PREFIX=" out)
+ ;; Otherwise looks for lrelease-qt4.
+ "QMAKE_LRELEASE=lrelease"
+ ;; Don't pester users about updates.
+ "DISABLE_UPDATE_CHECK=1")
+ #t)))
(add-after 'configure 'reset-resource-timestamps
(lambda _
;; The contents of build/release/.qrc/qrc_leocad.cpp generated by
@@ -113,8 +115,9 @@ restrictions that stem from limitations of the standard RCX firmware.")
(src (string-append base ".ts"))
(st (stat src)))
(set-file-time file st)))
- (find-files "." "leocad_.*\\.qm"))))))))
- (home-page "http://www.leocad.org")
+ (find-files "." "leocad_.*\\.qm")))
+ #t)))))
+ (home-page "https://www.leocad.org")
(synopsis "Create virtual Lego models")
(description
"LeoCAD is a program for creating virtual LEGO models. It has an