summaryrefslogtreecommitdiff
path: root/gnu/packages/kerberos.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kerberos.scm')
-rw-r--r--gnu/packages/kerberos.scm33
1 files changed, 26 insertions, 7 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index 34e70e7994..896d15f485 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -5,9 +5,11 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2012, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +35,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages libidn)
+ #:use-module (gnu packages hurd)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages compression)
@@ -49,7 +52,7 @@
(define-public mit-krb5
(package
(name "mit-krb5")
- (version "1.17")
+ (version "1.18")
(source (origin
(method url-fetch)
(uri (list
@@ -59,18 +62,34 @@
(string-append "https://kerberos.org/dist/krb5/"
(version-major+minor version)
"/krb5-" version ".tar.gz")))
+ (patches (search-patches "mit-krb5-qualify-short-hostnames.patch"
+ "mit-krb5-hurd.patch"))
(sha256
(base32
- "1xc1ly09697b7g2vngvx76szjqy9769kpgn27lnp1r9xln224vjs"))))
+ "121c5xsy3x0i4wdkrpw62yhvji6virbh6n30ypazkp0isws3k4bk"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
("perl" ,perl)))
(arguments
`(;; XXX: On 32-bit systems, 'kdb5_util' hangs on an fcntl/F_SETLKW call
- ;; while running the tests in 'src/tests'.
- #:tests? ,(string=? (%current-system) "x86_64-linux")
+ ;; while running the tests in 'src/tests'. Also disable tests when
+ ;; cross-compiling.
+ #:tests? ,(and (not (%current-target-system))
+ (string=? (%current-system) "x86_64-linux"))
+ ,@(if (%current-target-system)
+ '(#:configure-flags
+ (list "--localstatedir=/var"
+ "krb5_cv_attr_constructor_destructor=yes"
+ "ac_cv_func_regcomp=yes"
+ "ac_cv_printf_positional=yes"
+ "ac_cv_file__etc_environment=yes"
+ "ac_cv_file__etc_TIMEZONE=no")
+ #:make-flags
+ (list "CFLAGS+=-DDESTRUCTOR_ATTR_WORKS=1"))
+ '(#:configure-flags
+ (list "--localstatedir=/var")))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'enter-source-directory
@@ -78,8 +97,8 @@
(chdir "src")
#t))
(add-before 'check 'pre-check
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((perl (assoc-ref inputs "perl")))
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (let ((perl (assoc-ref (or native-inputs inputs) "perl")))
(substitute* "plugins/kdb/db2/libdb2/test/run.test"
(("/bin/cat") (string-append perl "/bin/perl"))
(("D/bin/sh") (string-append "D" (which "sh")))