summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm38
1 files changed, 21 insertions, 17 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index f39da03815..acaf25f745 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -2,10 +2,10 @@
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -170,36 +170,40 @@ SILC and ICB protocols via plugins.")
(define-public weechat
(package
(name "weechat")
- (version "2.6")
+ (version "2.7.1")
(source (origin
(method url-fetch)
(uri (string-append "https://weechat.org/files/src/weechat-"
version ".tar.xz"))
(sha256
(base32
- "0j2iflnfvv31q2l9r67r8aj3ipggqfm2r2dpy7pvdpxgwwq337ps"))))
+ "0haw0c35mf4r47j24issc9caq0da3fy7gjfq3454fm3ap3n2yxcx"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)
;; For tests.
("cpputest" ,cpputest)))
- (inputs `(("ncurses" ,ncurses)
- ("libgcrypt" ,libgcrypt "out")
- ("zlib" ,zlib)
- ("aspell" ,aspell)
- ("curl" ,curl)
- ("gnutls" ,gnutls)
+ (inputs
+ `(("aspell" ,aspell)
+ ("curl" ,curl)
+ ("gnutls" ,gnutls)
+ ("libgcrypt" ,libgcrypt "out")
+ ("ncurses" ,ncurses)
+ ("zlib" ,zlib)
- ;; Scripting language plug-ins.
- ("guile" ,guile-2.0)
- ("lua" ,lua-5.1)
- ("python" ,python)
- ("perl" ,perl)
- ("tcl" ,tcl)))
+ ;; Scripting language plug-ins.
+ ("guile" ,guile-2.2)
+ ("lua" ,lua-5.1)
+ ("perl" ,perl)
+ ("python" ,python)
+ ("tcl" ,tcl)))
(arguments
`(#:configure-flags
- (list "-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
+ (list "-DENABLE_JAVASCRIPT=OFF"
+ "-DENABLE_PHP=OFF"
+ "-DENABLE_RUBY=OFF"
+ "-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
;; Tests hang indefinately on non-Intel platforms.
#:tests? ,(if (any (cute string-prefix? <> (or (%current-target-system)
(%current-system)))